# CVE-2025-13643: MongoDB Server may allow queries to be terminated by unauthorized users

> Unauthorized users with limited privileges can terminate other users' queries, causing denial of service in MongoDB Server.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Nov 2025
- **Updated:** 25 Nov 2025
- **Also known as:** BIT-mongodb-2025-13643, GHSA-p2cp-6qqj-8xqc, MINI-gggw-j385-gv3m, MINI-p7xp-pch3-2rhm, UBUNTU-CVE-2025-13643

## What is CVE-2025-13643?

CVE-2025-13643 is a low-severity missing authorization vulnerability in Mongodb Mongodb, published on 25 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A user with access to the cluster with a limited set of privilege actions may be able to terminate queries that are being executed by other users. This may cause a denial of service by preventing a fraction of queries from successfully completing. This issue affects MongoDB Server v7.0 versions prior to 7.0.26 and MongoDB Server v8.0 versions prior to 8.0.14

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2025-13643?

1 open source package ship an affected version, including mongodb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mongodb` | Bitnami | From 7.0.0 | 7.0.26, 8.0.14 |

Products: Mongodb Mongodb.

## How do I fix CVE-2025-13643?

Upgrade mongodb to a fixed version for your release line: 7.0.26 or 8.0.14.

## Is CVE-2025-13643 being exploited?

There is no known exploitation of CVE-2025-13643 in the wild and no public exploit code.

## Other vulnerabilities in Mongodb Mongodb

- [CVE-2025-14847](https://insights.sbomify.com/CVE-2025-14847/): MongoDB and MongoDB Server Improper Handling of Length Parameter Inconsistency (high 8.7, exploited in the wild)
- [CVE-2026-82067](https://insights.sbomify.com/CVE-2026-82067/): Auth bypass in MongoDB Server (critical 9.2)
- [CVE-2026-13072](https://insights.sbomify.com/CVE-2026-13072/): MongoDB Improper Input Validation in Compute Mode External Data Processing Leading to Memory Corruption (critical 9.2)
- [CVE-2017-15535](https://insights.sbomify.com/CVE-2017-15535/): Denial of service in n/a (critical 9.1)
- [CVE-2026-18691](https://insights.sbomify.com/CVE-2026-18691/): Improper Authentication in MongoDB Intra-Cluster Connections Allows Credential Exposure (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-13643 and fix it if it is affected.

What it is: CVE-2025-13643 is a low-severity missing authorization vulnerability in Mongodb Mongodb, published on 25 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-13643 in the wild and no public exploit code.

Affected packages and fixed versions:
- mongodb (Bitnami): affected from 7.0.0; fixed in 7.0.26, 8.0.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-13643/ (Markdown: https://insights.sbomify.com/CVE-2025-13643/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-13643
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-13643
- OSV: https://osv.dev/vulnerability/CVE-2025-13643

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-13643/
Summaries are generated and may contain mistakes; the official description above is the record.
