CVE-2025-13644 MongoDB may be susceptible to Invariant Failure due to batched delete

High 7.1 Published Updated

An attacker can cause a denial of service in MongoDB Server by triggering an invariant failure during batched delete operations.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-13644?

CVE-2025-13644 is a high-severity denial of service vulnerability in Mongodb Mongodb, published on 25 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

MongoDB Server may experience an invariant failure during batched delete operations when handling documents. The issue arises when the server mistakenly assumes the presence of multiple documents in a batch based solely on document size exceeding BSONObjMaxSize. This issue affects MongoDB Server v7.0 versions prior to 7.0.26, MongoDB Server v8.0 versions prior to 8.0.13, and MongoDB Server v8.1 versions prior to 8.1.2

Weakness: CWE-617

Which versions are affected by CVE-2025-13644?

1 open source package ship an affected version, including mongodb. It affects 1 product.

PackageAffectedFixed in
mongodb BitnamiFrom 7.0.07.0.26, 8.0.13, 8.1.2

Products include Mongodb Mongodb.

How do I fix CVE-2025-13644?

Upgrade mongodb to a fixed version for your release line: 7.0.26, 8.0.13 or 8.1.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-13644 being exploited?

There is no known exploitation of CVE-2025-13644 in the wild and no public exploit code.

All Mongodb Mongodb vulnerabilities

Sources

Also known as BIT-mongodb-2025-13644, GHSA-73mg-mfgw-wp2f, MINI-493x-xjmp-h4mg, MINI-m4r4-873j-88v2.

Is CVE-2025-13644 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free