CVE-2025-13690 Allocation of Resources Without Limits or Throttling in GitLab

Medium 6.5 Published Updated

An authenticated user can cause a denial of service in GitLab by exploiting improper input validation on webhook custom header names.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-13690?

CVE-2025-13690 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 11 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 16.11 before 18.7.6, 18.8 before 18.8.6, and 18.9 before 18.9.2 that could have allowed an authenticated user to cause a denial of service condition due to improper input validation on webhook custom header names under certain conditions.

Weakness: CWE-770

Which versions are affected by CVE-2025-13690?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 16.11.018.7.6, 18.8.6, 18.9.2

Products include Gitlab Gitlab.

How do I fix CVE-2025-13690?

Upgrade gitlab to a fixed version for your release line: 18.7.6, 18.8.6 or 18.9.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-13690 being exploited?

There is no known exploitation of CVE-2025-13690 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-13690, GHSA-mgcq-rqq2-gc5f, UBUNTU-CVE-2025-13690.

Is CVE-2025-13690 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free