CVE-2025-13772 Missing Authorization in GitLab

High 7.1 Published Updated

Authenticated users can access AI model settings from unauthorized namespaces by manipulating API requests, requiring an upgrade to GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-13772?

CVE-2025-13772 is a high-severity missing authorization vulnerability in Gitlab Gitlab, published on 9 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab EE affecting all versions from 18.4 before 18.5.5, 18.6 before 18.6.3, and 18.7 before 18.7.1 that could have allowed an authenticated user to access and utilize AI model settings from unauthorized namespaces by manipulating namespace identifiers in API requests.

Weakness: CWE-862

Which versions are affected by CVE-2025-13772?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 18.4.018.5.5, 18.6.3, 18.7.1

Products include Gitlab Gitlab.

How do I fix CVE-2025-13772?

Upgrade gitlab to a fixed version for your release line: 18.5.5, 18.6.3 or 18.7.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-13772 being exploited?

There is no known exploitation of CVE-2025-13772 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-13772, GHSA-jxx7-c7v6-wh2p.

Is CVE-2025-13772 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free