CVE-2025-13781 Missing Authorization in GitLab

Medium 6.5 Published Updated

Authenticated users can modify instance-wide AI feature provider settings due to missing authorization checks in GraphQL mutations.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-13781?

CVE-2025-13781 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 9 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab EE affecting all versions from 18.5 before 18.5.5, 18.6 before 18.6.3, and 18.7 before 18.7.1 that could have allowed an authenticated user to modify instance-wide AI feature provider settings by exploiting missing authorization checks in GraphQL mutations.

Weakness: CWE-862

Which versions are affected by CVE-2025-13781?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 18.5.018.5.5, 18.6.3, 18.7.1

Products include Gitlab Gitlab.

How do I fix CVE-2025-13781?

Upgrade gitlab to a fixed version for your release line: 18.5.5, 18.6.3 or 18.7.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-13781 being exploited?

There is no known exploitation of CVE-2025-13781 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-13781, GHSA-p7gw-xwgf-7w7c.

Is CVE-2025-13781 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free