# CVE-2025-13822: Authentication bypass in MCPHub

> Unauthenticated attackers can bypass authentication on unprotected endpoints to perform actions and use privileges of other users.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:A/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Apr 2026
- **Updated:** 14 Apr 2026
- **Also known as:** GHSA-9vq7-9h42-j88h

## What is CVE-2025-13822?

CVE-2025-13822 is a medium-severity authentication bypass vulnerability in MCPHub, published on 14 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

MCPHub in versions below 0.11.0 is vulnerable to authentication bypass. Some endpoints are not protected by authentication middleware, allowing an unauthenticated attacker to perform actions in the name of other users and using their privileges.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2025-13822?

2 open source packages ship an affected version, including @samanhappy/mcphub. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@samanhappy/mcphub` | npm | All versions | 0.11.0 |
| `@samanhappy/mcphub` | npm | All versions | 0.11.0 |

Products: Mcphubx Mcphub.

## How do I fix CVE-2025-13822?

Upgrade @samanhappy/mcphub to 0.11.0 or later.

## Is CVE-2025-13822 being exploited?

There is no known exploitation of CVE-2025-13822 in the wild and no public exploit code.

## Other vulnerabilities in MCPHub

- [CVE-2025-11287](https://insights.sbomify.com/CVE-2025-11287/): samanhappy MCPHub sseService.ts handleSseConnectionfunction improper authentication (medium 6.9)
- [CVE-2025-11285](https://insights.sbomify.com/CVE-2025-11285/): samanhappy MCPHub serverController.ts os command injection (medium 5.3)
- [CVE-2025-11286](https://insights.sbomify.com/CVE-2025-11286/): samanhappy MCPHub MCPRouter Service serverController.ts server-side request forgery (medium 5.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-13822 and fix it if it is affected.

What it is: CVE-2025-13822 is a medium-severity authentication bypass vulnerability in MCPHub, published on 14 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-13822 in the wild and no public exploit code.

Affected packages and fixed versions:
- @samanhappy/mcphub (npm): affected all versions; fixed in 0.11.0
- @samanhappy/mcphub (npm): affected all versions; fixed in 0.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-13822/ (Markdown: https://insights.sbomify.com/CVE-2025-13822/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-13822
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-13822
- OSV: https://osv.dev/vulnerability/CVE-2025-13822

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-13822/
Summaries are generated and may contain mistakes; the official description above is the record.
