CVE-2025-13870 Unauthorized access and subscription vulnerability in Boards
Authenticated users can access files and subscribe to blocks in other boards due to missing permission checks in Mattermost Boards.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-13870?
CVE-2025-13870 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 2 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 10.11.x <= 10.11.4, 10.5.x <= 10.5.12 fail to validate the user permission when accessing the files and subscribing to the block in Boards, which allows an authenticated user to access other board files and was able to subscribe to the block from other boards that the user does not have access to
Weakness: CWE-306
Which versions are affected by CVE-2025-13870?
11 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost and github.com/mattermost/mattermost-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250905150616-ba86dfc5876b |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250905150616-ba86dfc5876b |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20251212204551-54f2e9b4afd5 |
github.com/mattermost/mattermost Go | From 10.11.0 | 10.11.5 |
github.com/mattermost/mattermost Go | From 10.11.0 | 10.11.5 |
github.com/mattermost/mattermost Go | From 10.5.0 | 10.5.13 |
5 more packages
github.com/mattermost/mattermost Go | From 10.5.0 | 10.5.13 |
github.com/mattermost/mattermost Go | From 10.5.0+incompatible | 10.5.13+incompatible, 10.11.5+incompatible |
github.com/mattermost/mattermost-server Go | All versions | None |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-13870?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20250905150616-ba86dfc5876b or 8.0.0-20251212204551-54f2e9b4afd5.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-13870 being exploited?
There is no known exploitation of CVE-2025-13870 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-58w6-w55x-6wq8, GO-2025-4178.