# CVE-2025-13870: Unauthorized access and subscription vulnerability in Boards

> Authenticated users can access files and subscribe to blocks in other boards due to missing permission checks in Mattermost Boards.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Dec 2025
- **Updated:** 2 Dec 2025
- **Also known as:** GHSA-58w6-w55x-6wq8, GO-2025-4178

## What is CVE-2025-13870?

CVE-2025-13870 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 2 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost versions 10.11.x <= 10.11.4, 10.5.x <= 10.5.12 fail to validate the user permission when accessing the files and subscribing to the block in Boards, which allows an authenticated user to access other board files and was able to subscribe to the block from other boards that the user does not have access to

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2025-13870?

11 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost and github.com/mattermost/mattermost-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250905150616-ba86dfc5876b |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250905150616-ba86dfc5876b |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20251212204551-54f2e9b4afd5 |
| `github.com/mattermost/mattermost` | Go | From 10.11.0 | 10.11.5 |
| `github.com/mattermost/mattermost` | Go | From 10.11.0 | 10.11.5 |
| `github.com/mattermost/mattermost` | Go | From 10.5.0 | 10.5.13 |
| `github.com/mattermost/mattermost` | Go | From 10.5.0 | 10.5.13 |
| `github.com/mattermost/mattermost` | Go | From 10.5.0+incompatible | 10.5.13+incompatible, 10.11.5+incompatible |
| `github.com/mattermost/mattermost-server` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2025-13870?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20250905150616-ba86dfc5876b or 8.0.0-20251212204551-54f2e9b4afd5.

## Is CVE-2025-13870 being exploited?

There is no known exploitation of CVE-2025-13870 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-13870 and fix it if it is affected.

What it is: CVE-2025-13870 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 2 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-13870 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250905150616-ba86dfc5876b
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250905150616-ba86dfc5876b
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20251212204551-54f2e9b4afd5
- github.com/mattermost/mattermost (Go): affected from 10.11.0; fixed in 10.11.5
- github.com/mattermost/mattermost (Go): affected from 10.11.0; fixed in 10.11.5
- github.com/mattermost/mattermost (Go): affected from 10.5.0; fixed in 10.5.13
- github.com/mattermost/mattermost (Go): affected from 10.5.0; fixed in 10.5.13
- github.com/mattermost/mattermost (Go): affected from 10.5.0+incompatible; fixed in 10.5.13+incompatible, 10.11.5+incompatible
- github.com/mattermost/mattermost-server (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v6 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-13870/ (Markdown: https://insights.sbomify.com/CVE-2025-13870/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-13870
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-13870
- OSV: https://osv.dev/vulnerability/CVE-2025-13870

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-13870/
Summaries are generated and may contain mistakes; the official description above is the record.
