CVE-2025-13877 nocobase JWT Service jwt-service.ts hard-coded key
Attackers can exploit a hard-coded JWT key in Nocobase to bypass authentication and potentially take over accounts.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-13877?
CVE-2025-13877 is a medium-severity vulnerability in nocobase, published on 2 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A vulnerability was detected in nocobase up to 1.9.4/2.0.0-alpha.37. The affected element is an unknown function of the file nocobase\packages\core\auth\src\base\jwt-service.ts of the component JWT Service. The manipulation of the argument API_KEY results in use of hard-coded cryptographic key . The attack can be launched remotely. A high complexity level is associated with this attack. The exploitability is described as difficult. The exploit is now public and may be used. The vendor was contacted early about this disclosure but did not respond in any way.
Which versions are affected by CVE-2025-13877?
6 open source packages ship an affected version, including @nocobase/auth.
| Package | Affected | Fixed in |
|---|---|---|
@nocobase/auth npm | All versions | 1.9.0-beta.18 |
@nocobase/auth npm | All versions | 1.9.0-beta.18 |
@nocobase/auth npm | From 1.9.0 | 1.9.23 |
@nocobase/auth npm | From 1.9.0 | 1.9.23 |
@nocobase/auth npm | From 2.0.0-alpha.1 | 2.0.0-alpha.52 |
@nocobase/auth npm | From 2.0.0-alpha.1 | 2.0.0-alpha.52 |
How do I fix CVE-2025-13877?
Upgrade @nocobase/auth to a fixed version for your release line: 1.9.0-beta.18, 1.9.23 or 2.0.0-alpha.52.
Is CVE-2025-13877 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-13877 exists.
Sources
Also known as GHSA-mv7p-34fv-4874.