# CVE-2025-13877: nocobase JWT Service jwt-service.ts hard-coded key

> Attackers can exploit a hard-coded JWT key in Nocobase to bypass authentication and potentially take over accounts.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Dec 2025
- **Updated:** 2 Dec 2025
- **Also known as:** GHSA-mv7p-34fv-4874

## What is CVE-2025-13877?

CVE-2025-13877 is a medium-severity vulnerability in nocobase, published on 2 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability was detected in nocobase up to 1.9.4/2.0.0-alpha.37. The affected element is an unknown function of the file nocobase\packages\core\auth\src\base\jwt-service.ts of the component JWT Service. The manipulation of the argument API_KEY results in use of hard-coded cryptographic key . The attack can be launched remotely. A high complexity level is associated with this attack. The exploitability is described as difficult. The exploit is now public and may be used. The vendor was contacted early about this disclosure but did not respond in any way.

Weakness: CWE-321 (Use of Hard-coded Cryptographic Key), CWE-320

## Which versions are affected by CVE-2025-13877?

6 open source packages ship an affected version, including @nocobase/auth.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@nocobase/auth` | npm | All versions | 1.9.0-beta.18 |
| `@nocobase/auth` | npm | All versions | 1.9.0-beta.18 |
| `@nocobase/auth` | npm | From 1.9.0 | 1.9.23 |
| `@nocobase/auth` | npm | From 1.9.0 | 1.9.23 |
| `@nocobase/auth` | npm | From 2.0.0-alpha.1 | 2.0.0-alpha.52 |
| `@nocobase/auth` | npm | From 2.0.0-alpha.1 | 2.0.0-alpha.52 |

## How do I fix CVE-2025-13877?

Upgrade @nocobase/auth to a fixed version for your release line: 1.9.0-beta.18, 1.9.23 or 2.0.0-alpha.52.

## Is CVE-2025-13877 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-13877 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-13877 and fix it if it is affected.

What it is: CVE-2025-13877 is a medium-severity vulnerability in nocobase, published on 2 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-13877 exists.

Affected packages and fixed versions:
- @nocobase/auth (npm): affected all versions; fixed in 1.9.0-beta.18
- @nocobase/auth (npm): affected all versions; fixed in 1.9.0-beta.18
- @nocobase/auth (npm): affected from 1.9.0; fixed in 1.9.23
- @nocobase/auth (npm): affected from 1.9.0; fixed in 1.9.23
- @nocobase/auth (npm): affected from 2.0.0-alpha.1; fixed in 2.0.0-alpha.52
- @nocobase/auth (npm): affected from 2.0.0-alpha.1; fixed in 2.0.0-alpha.52

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-13877/ (Markdown: https://insights.sbomify.com/CVE-2025-13877/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-13877
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-13877
- OSV: https://osv.dev/vulnerability/CVE-2025-13877

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-13877/
Summaries are generated and may contain mistakes; the official description above is the record.
