# CVE-2025-13888: Openshift-gitops-operator: openshift gitops: namespace admin cluster takeover via privileged jobs

> Namespace admins can escalate privileges to gain root access on master nodes by creating malicious ArgoCD Custom Resources in OpenShift GitOps.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Dec 2025
- **Updated:** 22 Jan 2026
- **Also known as:** GHSA-pcqx-8qww-7f4v, GO-2025-4242

## What is CVE-2025-13888?

CVE-2025-13888 is a critical vulnerability in Red Hat OpenShift GitOps, published on 15 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A flaw was found in OpenShift GitOps. Namespace admins can create ArgoCD Custom Resources (CRs) that trick the system into granting them elevated permissions in other namespaces, including privileged namespaces. An authenticated attacker can then use these elevated permissions to create privileged workloads that run on master nodes, effectively giving them root access to the entire cluster.

Weakness: CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2025-13888?

3 open source packages ship an affected version, including github.com/redhat-developer/gitops-operator.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/redhat-developer/gitops-operator` | Go | All versions | None |
| `github.com/redhat-developer/gitops-operator` | Go | All versions | 1.16.2 |
| `github.com/redhat-developer/gitops-operator` | Go | All versions | 1.16.2 |

## How do I fix CVE-2025-13888?

Upgrade github.com/redhat-developer/gitops-operator to 1.16.2 or later.

## Is CVE-2025-13888 being exploited?

There is no known exploitation of CVE-2025-13888 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-13888 and fix it if it is affected.

What it is: CVE-2025-13888 is a critical vulnerability in Red Hat OpenShift GitOps, published on 15 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-13888 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/redhat-developer/gitops-operator (Go): affected all versions; no fix listed
- github.com/redhat-developer/gitops-operator (Go): affected all versions; fixed in 1.16.2
- github.com/redhat-developer/gitops-operator (Go): affected all versions; fixed in 1.16.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-13888/ (Markdown: https://insights.sbomify.com/CVE-2025-13888/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-13888
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-13888
- OSV: https://osv.dev/vulnerability/CVE-2025-13888

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-13888/
Summaries are generated and may contain mistakes; the official description above is the record.
