# CVE-2025-13921: weDocs <= 2.1.16 - Missing Authorization to Authenticated (Subscriber+) Documentation Post Update

> Authenticated subscribers can modify any documentation post due to missing capability checks in the weDocs WordPress plugin.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 23 Jan 2026
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-qwh9-h352-5pg4

## What is CVE-2025-13921?

CVE-2025-13921 is a medium-severity missing authorization vulnerability in wedevs weDocs: AI Powered Knowledge Base, Docs, Documentation, Wiki & AI Chatbot, published on 23 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The weDocs: AI Powered Knowledge Base, Docs, Documentation, Wiki & AI Chatbot plugin for WordPress is vulnerable to unauthorized modification or loss of data due to a missing capability check on the 'wedocs_user_documentation_handling_capabilities' function in all versions up to, and including, 2.1.16. This makes it possible for authenticated attackers, with Subscriber-level access and above, to edit any documentation post. The vulnerability was partially patched in version 2.1.16.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2025-13921?


## How do I fix CVE-2025-13921?

No fix has been published for CVE-2025-13921 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-13921 being exploited?

There is no known exploitation of CVE-2025-13921 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-13921 and fix it if it is affected.

What it is: CVE-2025-13921 is a medium-severity missing authorization vulnerability in wedevs weDocs: AI Powered Knowledge Base, Docs, Documentation, Wiki & AI Chatbot, published on 23 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-13921 in the wild and no public exploit code.

Affected product: wedevs weDocs: AI Powered Knowledge Base, Docs, Documentation, Wiki & AI Chatbot. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-13921/ (Markdown: https://insights.sbomify.com/CVE-2025-13921/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-13921
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-13921
- OSV: https://osv.dev/vulnerability/CVE-2025-13921

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-13921/
Summaries are generated and may contain mistakes; the official description above is the record.
