CVE-2025-13927 Allocation of Resources Without Limits or Throttling in GitLab

High 7.5 Published Updated

Unauthenticated attackers can cause denial of service in GitLab by sending crafted requests with malformed authentication data.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-13927?

CVE-2025-13927 is a high-severity denial of service vulnerability in Gitlab Gitlab, published on 22 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 11.9 before 18.6.4, 18.7 before 18.7.2, and 18.8 before 18.8.2 that could have allowed an unauthenticated user to create a denial of service condition by sending crafted requests with malformed authentication data.

Weakness: CWE-770

Which versions are affected by CVE-2025-13927?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 11.9.018.6.4, 18.7.2, 18.8.2

Products include Gitlab Gitlab.

How do I fix CVE-2025-13927?

Upgrade gitlab to a fixed version for your release line: 18.6.4, 18.7.2 or 18.8.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-13927 being exploited?

There is no known exploitation of CVE-2025-13927 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-13927, GHSA-4v3f-ffrw-xcx6, MINI-2cjp-jw7m-25wc, MINI-2hgg-77pr-2hfr, MINI-2x7w-76mj-mp5j, MINI-4788-qpff-9vq7 and 24 more.

Is CVE-2025-13927 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free