CVE-2025-13928 Incorrect Authorization in GitLab

High 7.5 Published Updated

An unauthenticated attacker can cause a denial of service in GitLab by exploiting incorrect authorization validation in API endpoints.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-13928?

CVE-2025-13928 is a high-severity missing authorization vulnerability in Gitlab Gitlab, published on 22 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 17.7 before 18.6.4, 18.7 before 18.7.2, and 18.8 before 18.8.2 that could have allowed an unauthenticated user to cause a denial of service condition by exploiting incorrect authorization validation in API endpoints.

Weakness: CWE-863

Which versions are affected by CVE-2025-13928?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 17.7.018.6.4, 18.7.2, 18.8.2

Products include Gitlab Gitlab.

How do I fix CVE-2025-13928?

Upgrade gitlab to a fixed version for your release line: 18.6.4, 18.7.2 or 18.8.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-13928 being exploited?

There is no known exploitation of CVE-2025-13928 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-13928, GHSA-rf7g-f56c-v6w4, MINI-243h-pr63-h8rv, MINI-2m6m-9pp3-x7cr, MINI-3vqc-p2hf-fffm, MINI-5jqm-qm7f-rcxq and 25 more.

Is CVE-2025-13928 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free