CVE-2025-13978 Generation of Error Message Containing Sensitive Information in GitLab

Medium 4.3 Published Updated

Authenticated users can discover names of private projects they lack access to via API requests, requiring an upgrade to GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-13978?

CVE-2025-13978 is a medium-severity vulnerability in Gitlab Gitlab, published on 11 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 17.5 before 18.4.6, 18.5 before 18.5.4, and 18.6 before 18.6.2 that could have allowed an authenticated user to discover the names of private projects they do not have access through API requests.

Weakness: CWE-209

Which versions are affected by CVE-2025-13978?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 17.5.018.4.6, 18.5.4, 18.6.2

Products include Gitlab Gitlab.

How do I fix CVE-2025-13978?

Upgrade gitlab to a fixed version for your release line: 18.4.6, 18.5.4 or 18.6.2.

Is CVE-2025-13978 being exploited?

There is no known exploitation of CVE-2025-13978 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-13978, ECHO-8e5f-dc7c-1b92, GHSA-mp63-3qcj-f8c7, UBUNTU-CVE-2025-13978.

Is CVE-2025-13978 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free