{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-13979 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2025-13979 is a medium-severity cross-site scripting vulnerability in Drupal Mini site, published on 28 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-13979 and fix it if it is affected.\n\nWhat it is: CVE-2025-13979 is a medium-severity cross-site scripting vulnerability in Drupal Mini site, published on 28 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-13979 in the wild and no public exploit code.\n\nAffected product: Drupal Mini site. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-13979/ (Markdown: https://insights.sbomify.com/CVE-2025-13979/index.md)","id":"CVE-2025-13979","markdown":"https://insights.sbomify.com/CVE-2025-13979/index.md","name":"CVE-2025-13979","record":{"aliases":["DRUPAL-CONTRIB-2025-117","GHSA-mwgm-j9q4-3cm5"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal Mini site","requires_auth":"low_privilege","summary":"An attacker can inject malicious scripts into the Drupal Mini site module, potentially leading to session hijacking or unauthorized actions.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"mini_site","vendor":"salsa.digital"}],"cvss":{"score":5.4,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-267","name":"Privilege Defined With Unsafe Actions"}],"description":"Privilege Defined With Unsafe Actions vulnerability in Drupal Mini site allows Stored XSS.This issue affects Mini site: from 0.0.0 before 3.0.2.","ecosystems":["Packagist:https://packages.drupal.org/8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Mini site - Moderately critical - Cross-Site Scripting - SA-CONTRIB-2025-117","id":"CVE-2025-13979","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2025"},"n_packages":1,"n_references":1,"next":{"headline":"CKEditor 5 Premium Features - Moderately critical - Access bypass - SA-CONTRIB-2025-118","id":"CVE-2025-13980"},"packages":[{"ecosystem":"Packagist:https://packages.drupal.org/8","fixed":["3.0.2"],"introduced":["0"],"last_affected":[],"package":"drupal/minisite","purl":"pkg:composer/drupal/minisite?repository_url=https:%2F%2Fpackages.drupal.org%2F8","source":"DRUPAL-CONTRIB-2025-117"}],"prev":{"headline":"Generation of Error Message Containing Sensitive Information in GitLab","id":"CVE-2025-13978"},"products":["Mini site"],"published":"2026-01-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"MIT","name":"Drupal","prefix":"DRUPAL"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-29","vendors":["Drupal"]},"summary":"An attacker can inject malicious scripts into the Drupal Mini site module, potentially leading to session hijacking or unauthorized actions.","url":"https://insights.sbomify.com/CVE-2025-13979/"}