# CVE-2025-1398: macOS TCC Bypass via Code Injection

> An attacker with remote access can bypass macOS TCC protections via code injection due to unnecessary entitlements in the Mattermost Desktop App.

- **Severity:** Low 3.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Mar 2025
- **Updated:** 31 Mar 2025
- **Also known as:** GHSA-xmvv-w44w-j8wx

## What is CVE-2025-1398?

CVE-2025-1398 is a low-severity vulnerability in Mattermost, published on 17 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Mattermost Desktop App versions <=5.10.0 explicitly declared unnecessary macOS entitlements which allows an attacker with remote access to bypass Transparency, Consent, and Control (TCC) via code injection.

Weakness: CWE-426 (Untrusted Search Path)

## Which versions are affected by CVE-2025-1398?

2 open source packages ship an affected version, including mattermost-desktop. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mattermost-desktop` | npm | All versions | 5.11.0 |
| `mattermost-desktop` | npm | All versions | 5.11.0 |

Products: Mattermost Mattermost Desktop.

## How do I fix CVE-2025-1398?

Upgrade mattermost-desktop to 5.11.0 or later.

## Is CVE-2025-1398 being exploited?

There is no known exploitation of CVE-2025-1398 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost

- [CVE-2016-11064](https://insights.sbomify.com/CVE-2016-11064/): Code injection in n/a (critical 9.8)
- [CVE-2019-20856](https://insights.sbomify.com/CVE-2019-20856/): Code injection in n/a (critical 9.8)
- [CVE-2019-20861](https://insights.sbomify.com/CVE-2019-20861/): Code injection in n/a (high 8.8)
- [CVE-2026-1046](https://insights.sbomify.com/CVE-2026-1046/): Arbitrary application execution via unvalidated server-controlled URLs in Help menu (high 7.6)
- [CVE-2020-14456](https://insights.sbomify.com/CVE-2020-14456/): Security feature bypass in n/a (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-1398 and fix it if it is affected.

What it is: CVE-2025-1398 is a low-severity vulnerability in Mattermost, published on 17 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-1398 in the wild and no public exploit code.

Affected packages and fixed versions:
- mattermost-desktop (npm): affected all versions; fixed in 5.11.0
- mattermost-desktop (npm): affected all versions; fixed in 5.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-1398/ (Markdown: https://insights.sbomify.com/CVE-2025-1398/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-1398
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-1398
- OSV: https://osv.dev/vulnerability/CVE-2025-1398

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-1398/
Summaries are generated and may contain mistakes; the official description above is the record.
