{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-13984 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2025-13984 is a medium-severity cross-site scripting vulnerability in Drupal Next.js, published on 28 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-13984 and fix it if it is affected.\n\nWhat it is: CVE-2025-13984 is a medium-severity cross-site scripting vulnerability in Drupal Next.js, published on 28 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-13984 in the wild and no public exploit code.\n\nAffected product: Drupal Next.js. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-13984/ (Markdown: https://insights.sbomify.com/CVE-2025-13984/index.md)","id":"CVE-2025-13984","markdown":"https://insights.sbomify.com/CVE-2025-13984/index.md","name":"CVE-2025-13984","record":{"aliases":["DRUPAL-CONTRIB-2025-122","GHSA-2fw7-6f7r-fx94"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal Next.js module","requires_auth":"none","summary":"A permissive cross-domain security policy in the Drupal Next.js module allows attackers to execute Cross-Site Scripting (XSS) attacks.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"next.js","vendor":"kanopi"}],"cvss":{"score":6.1,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-942","name":"Permissive Cross-domain Security Policy with Untrusted Domains"}],"description":"Permissive Cross-domain Security Policy with Untrusted Domains vulnerability in Drupal Next.Js allows Cross-Site Scripting (XSS).This issue affects Next.Js: from 0.0.0 before 1.6.4, from 2.0.0 before 2.0.1.","ecosystems":["Packagist:https://packages.drupal.org/8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Next.js - Critical - Access bypass - SA-CONTRIB-2025-122","id":"CVE-2025-13984","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2025"},"n_packages":1,"n_references":1,"next":{"headline":"Entity Share - Moderately critical - Access bypass, Information Disclosure - SA-CONTRIB-2025-123","id":"CVE-2025-13985"},"packages":[{"ecosystem":"Packagist:https://packages.drupal.org/8","fixed":["1.6.4","2.0.1"],"introduced":["0","2.0.0"],"last_affected":[],"package":"drupal/next","purl":"pkg:composer/drupal/next?repository_url=https:%2F%2Fpackages.drupal.org%2F8","source":"DRUPAL-CONTRIB-2025-122"}],"prev":{"headline":"Tagify - Moderately critical - Cross-site Scripting - SA-CONTRIB-2025-121","id":"CVE-2025-13983"},"products":["Next.js"],"published":"2026-01-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"MIT","name":"Drupal","prefix":"DRUPAL"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-29","vendors":["Drupal"]},"summary":"A permissive cross-domain security policy in the Drupal Next.js module allows attackers to execute Cross-Site Scripting (XSS) attacks.","url":"https://insights.sbomify.com/CVE-2025-13984/"}