{"answers":{"affected":"3 open source packages ship an affected version, including nltk. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14009 exists.","fix":"Upgrade nltk to 3.9.3 or later.","what":"CVE-2025-14009 is a critical path traversal vulnerability in nltk/nltk, published on 18 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-14009 and fix it if it is affected.\n\nWhat it is: CVE-2025-14009 is a critical path traversal vulnerability in nltk/nltk, published on 18 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14009 exists.\n\nAffected packages and fixed versions:\n- nltk (PyPI): affected all versions; fixed in 3.9.3\n- nltk (PyPI): affected all versions; fixed in 3.9.3\n- nltk (PyPI): affected all versions; fixed in 3.9.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-14009/ (Markdown: https://insights.sbomify.com/CVE-2025-14009/index.md)","id":"CVE-2025-14009","markdown":"https://insights.sbomify.com/CVE-2025-14009/index.md","name":"CVE-2025-14009","record":{"aliases":["DEBIAN-CVE-2025-14009","ECHO-a2cb-9feb-100c","GHSA-7p94-766c-hgjp","PYSEC-2026-96","ROOT-APP-PYPI-CVE-2025-14009","UBUNTU-CVE-2025-14009","openSUSE-SU-2026:10226-1"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python NLP library","requires_auth":"none","summary":"Attackers can achieve remote code execution by crafting malicious zip packages that exploit path traversal in the NLTK downloader.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[{"product":"nltk","vendor":"nltk"}],"cvss":{"score":10,"severity":"critical","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"A critical vulnerability exists in the NLTK downloader component of nltk/nltk, affecting all versions. The _unzip_iter function in nltk/downloader.py uses zipfile.extractall() without performing path validation or security checks. This allows attackers to craft malicious zip packages that, when downloaded and extracted by NLTK, can execute arbitrary code. The vulnerability arises because NLTK assumes all downloaded packages are trusted and extracts them without validation. If a malicious package contains Python files, such as __init__.py, these files are executed automatically upon import, leading to remote code execution. This issue can result in full system compromise, including file system access, network access, and potential persistence mechanisms.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Zip Slip Vulnerability in nltk/nltk Leading to Remote Code Execution","id":"CVE-2025-14009","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2025"},"n_packages":4,"n_references":1,"next":{"headline":"Ansible Community General Collection is vulnerable to exposure of sensitive information","id":"CVE-2025-14010"},"packages":[{"ecosystem":"PyPI","fixed":["3.9.3"],"introduced":["0"],"last_affected":[],"package":"nltk","purl":null,"source":"GHSA-7p94-766c-hgjp"},{"ecosystem":"PyPI","fixed":["3.9.3"],"introduced":["0"],"last_affected":[],"package":"nltk","purl":"pkg:pypi/nltk","source":"GHSA-7p94-766c-hgjp"},{"ecosystem":"PyPI","fixed":["3.9.3"],"introduced":["0"],"last_affected":[],"package":"nltk","purl":"pkg:pypi/nltk","source":"PYSEC-2026-96"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["3.9.1-3.1"],"introduced":["0"],"last_affected":[],"package":"python-nltk","purl":"pkg:rpm/opensuse/python-nltk\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10226-1"}],"prev":{"headline":"dayrui XunRuiCMS Project Domain Change Test admin79f2ec220c7e.php server-side request forgery","id":"CVE-2025-14008"},"products":["nltk/nltk"],"published":"2026-02-18","related":[{"cvss_score":10,"headline":"Arbitrary Code Execution in NLTK StanfordSegmenter via Untrusted JAR Loading","id":"CVE-2026-0848","kev_date_added":null,"published":"2026-03-05"},{"cvss_score":9.4,"headline":"NLTK before 3.10.0 Remote Code Execution via Unsafe Pickle Deserialization","id":"CVE-2026-78683","kev_date_added":null,"published":"2026-08-25"},{"cvss_score":9.3,"headline":"NLTK before 3.10.3 Remote Code Execution via Unsafe Pickle Deserialization","id":"CVE-2026-79657","kev_date_added":null,"published":"2026-08-25"},{"cvss_score":9.3,"headline":"NLTK before 3.10.3 JVM Argument Injection via Per-Call Options","id":"CVE-2026-79675","kev_date_added":null,"published":"2026-08-25"},{"cvss_score":8.8,"headline":"NLTK 3.10.2 Path Traversal via corpus-reader constructors","id":"CVE-2026-79674","kev_date_added":null,"published":"2026-08-25"},{"cvss_score":8.7,"headline":"nltk PorterStemmer before 3.10.3 Quadratic-time DoS","id":"CVE-2026-81722","kev_date_added":null,"published":"2026-08-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-15","vendors":["nltk"]},"summary":"Attackers can achieve remote code execution by crafting malicious zip packages that exploit path traversal in the NLTK downloader.","url":"https://insights.sbomify.com/CVE-2025-14009/"}