# CVE-2025-14009: Zip Slip Vulnerability in nltk/nltk Leading to Remote Code Execution

> Attackers can achieve remote code execution by crafting malicious zip packages that exploit path traversal in the NLTK downloader.

- **Severity:** Critical 10.0 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Feb 2026
- **Updated:** 15 Jul 2026
- **Also known as:** DEBIAN-CVE-2025-14009, ECHO-a2cb-9feb-100c, GHSA-7p94-766c-hgjp, PYSEC-2026-96, ROOT-APP-PYPI-CVE-2025-14009, UBUNTU-CVE-2025-14009, openSUSE-SU-2026:10226-1

## What is CVE-2025-14009?

CVE-2025-14009 is a critical path traversal vulnerability in nltk/nltk, published on 18 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A critical vulnerability exists in the NLTK downloader component of nltk/nltk, affecting all versions. The _unzip_iter function in nltk/downloader.py uses zipfile.extractall() without performing path validation or security checks. This allows attackers to craft malicious zip packages that, when downloaded and extracted by NLTK, can execute arbitrary code. The vulnerability arises because NLTK assumes all downloaded packages are trusted and extracts them without validation. If a malicious package contains Python files, such as __init__.py, these files are executed automatically upon import, leading to remote code execution. This issue can result in full system compromise, including file system access, network access, and potential persistence mechanisms.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2025-14009?

3 open source packages ship an affected version, including nltk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nltk` | PyPI | All versions | 3.9.3 |
| `nltk` | PyPI | All versions | 3.9.3 |
| `nltk` | PyPI | All versions | 3.9.3 |
| `python-nltk` | openSUSE:Tumbleweed | All versions | 3.9.1-3.1 |

Products: Nltk Nltk.

## How do I fix CVE-2025-14009?

Upgrade nltk to 3.9.3 or later.

## Is CVE-2025-14009 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14009 exists.

## Other vulnerabilities in nltk/nltk

- [CVE-2026-0848](https://insights.sbomify.com/CVE-2026-0848/): Arbitrary Code Execution in NLTK StanfordSegmenter via Untrusted JAR Loading (critical 10.0)
- [CVE-2026-78683](https://insights.sbomify.com/CVE-2026-78683/): NLTK before 3.10.0 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.4)
- [CVE-2026-79657](https://insights.sbomify.com/CVE-2026-79657/): NLTK before 3.10.3 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.3)
- [CVE-2026-79675](https://insights.sbomify.com/CVE-2026-79675/): NLTK before 3.10.3 JVM Argument Injection via Per-Call Options (critical 9.3)
- [CVE-2026-79674](https://insights.sbomify.com/CVE-2026-79674/): NLTK 3.10.2 Path Traversal via corpus-reader constructors (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-14009 and fix it if it is affected.

What it is: CVE-2025-14009 is a critical path traversal vulnerability in nltk/nltk, published on 18 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14009 exists.

Affected packages and fixed versions:
- nltk (PyPI): affected all versions; fixed in 3.9.3
- nltk (PyPI): affected all versions; fixed in 3.9.3
- nltk (PyPI): affected all versions; fixed in 3.9.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-14009/ (Markdown: https://insights.sbomify.com/CVE-2025-14009/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-14009
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-14009
- OSV: https://osv.dev/vulnerability/CVE-2025-14009

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-14009/
Summaries are generated and may contain mistakes; the official description above is the record.
