{"answers":{"affected":"3 open source packages ship an affected version, including ansible. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14010 exists.","fix":"Upgrade ansible to 12.2.0 or later.","what":"CVE-2025-14010 is a medium-severity vulnerability in Red Hat Ansible Community General Collection, published on 4 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-14010 and fix it if it is affected.\n\nWhat it is: CVE-2025-14010 is a medium-severity vulnerability in Red Hat Ansible Community General Collection, published on 4 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14010 exists.\n\nAffected packages and fixed versions:\n- ansible (PyPI): affected all versions; fixed in 12.2.0\n- ansible (PyPI): affected all versions; fixed in 12.2.0\n- ansible (PyPI): affected all versions; fixed in 12.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-14010/ (Markdown: https://insights.sbomify.com/CVE-2025-14010/index.md)","id":"CVE-2025-14010","markdown":"https://insights.sbomify.com/CVE-2025-14010/index.md","name":"CVE-2025-14010","record":{"aliases":["DEBIAN-CVE-2025-14010","GHSA-8ggh-xwr9-3373","PYSEC-2026-1119","UBUNTU-CVE-2025-14010"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Ansible collection","requires_auth":"low_privilege","summary":"Ansible Keycloak module leaks plaintext passwords in verbose logs, allowing attackers with log access to compromise accounts.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"community.general","vendor":"redhat"}],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-532","name":"Insertion of Sensitive Information into Log File"}],"description":"A flaw was found in ansible-collection-community-general. This vulnerability allows for information exposure (IE) of sensitive credentials, specifically plaintext passwords, via verbose output when running Ansible with debug modes. Attackers with access to logs could retrieve these secrets and potentially compromise Keycloak accounts or administrative access.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Ansible Community General Collection is vulnerable to exposure of sensitive information","id":"CVE-2025-14010","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"information_disclosure","year":"2025"},"n_packages":3,"n_references":5,"next":{"headline":"JIZHICMS Add Display Name Field addcomment.html commentlist sql injection","id":"CVE-2025-14011"},"packages":[{"ecosystem":"PyPI","fixed":["12.2.0"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":null,"source":"GHSA-8ggh-xwr9-3373"},{"ecosystem":"PyPI","fixed":["12.2.0"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"GHSA-8ggh-xwr9-3373"},{"ecosystem":"PyPI","fixed":["12.2.0"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"PYSEC-2026-1119"}],"prev":{"headline":"Zip Slip Vulnerability in nltk/nltk Leading to Remote Code Execution","id":"CVE-2025-14009"},"products":["Ansible Community General Collection","Red Hat Ceph Storage 5","Red Hat Ceph Storage 6","Red Hat Ceph Storage 7","Red Hat Ceph Storage 8","Red Hat OpenStack Platform 17.1","Red Hat OpenStack Platform 18.0"],"published":"2025-12-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-20","vendors":["Red Hat","ansible-collections"]},"summary":"Ansible Keycloak module leaks plaintext passwords in verbose logs, allowing attackers with log access to compromise accounts.","url":"https://insights.sbomify.com/CVE-2025-14010/"}