# CVE-2025-14010: Ansible Community General Collection is vulnerable to exposure of sensitive information

> Ansible Keycloak module leaks plaintext passwords in verbose logs, allowing attackers with log access to compromise accounts.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Dec 2025
- **Updated:** 20 May 2026
- **Also known as:** DEBIAN-CVE-2025-14010, GHSA-8ggh-xwr9-3373, PYSEC-2026-1119, UBUNTU-CVE-2025-14010

## What is CVE-2025-14010?

CVE-2025-14010 is a medium-severity vulnerability in Red Hat Ansible Community General Collection, published on 4 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A flaw was found in ansible-collection-community-general. This vulnerability allows for information exposure (IE) of sensitive credentials, specifically plaintext passwords, via verbose output when running Ansible with debug modes. Attackers with access to logs could retrieve these secrets and potentially compromise Keycloak accounts or administrative access.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2025-14010?

3 open source packages ship an affected version, including ansible. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | All versions | 12.2.0 |
| `ansible` | PyPI | All versions | 12.2.0 |
| `ansible` | PyPI | All versions | 12.2.0 |

Products: Redhat Community.general.

## How do I fix CVE-2025-14010?

Upgrade ansible to 12.2.0 or later.

## Is CVE-2025-14010 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14010 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-14010 and fix it if it is affected.

What it is: CVE-2025-14010 is a medium-severity vulnerability in Red Hat Ansible Community General Collection, published on 4 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14010 exists.

Affected packages and fixed versions:
- ansible (PyPI): affected all versions; fixed in 12.2.0
- ansible (PyPI): affected all versions; fixed in 12.2.0
- ansible (PyPI): affected all versions; fixed in 12.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-14010/ (Markdown: https://insights.sbomify.com/CVE-2025-14010/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-14010
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-14010
- OSV: https://osv.dev/vulnerability/CVE-2025-14010

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-14010/
Summaries are generated and may contain mistakes; the official description above is the record.
