{"answers":{"affected":"6 open source packages ship an affected version, including qiskit and qiskit-terra. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-1403 in the wild and no public exploit code.","fix":"Upgrade qiskit to 1.3.0 or later.","what":"CVE-2025-1403 is a high-severity denial of service vulnerability in IBM Qiskit SDK, published on 21 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-1403 and fix it if it is affected.\n\nWhat it is: CVE-2025-1403 is a high-severity denial of service vulnerability in IBM Qiskit SDK, published on 21 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-1403 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- qiskit (PyPI): affected from 0.45.0; fixed in 1.3.0\n- qiskit (PyPI): affected from 0.45.0; fixed in 1.3.0\n- qiskit (PyPI): affected from 0.45.0; fixed in 1.3.0\n- qiskit-terra (PyPI): affected from 0.45.0 up to 0.46.3; no fix listed\n- qiskit-terra (PyPI): affected from 0.45.0 up to 0.46.3; no fix listed\n- qiskit-terra (PyPI): affected from 0.45.0 up to 0.46.3; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-1403/ (Markdown: https://insights.sbomify.com/CVE-2025-1403/index.md)","id":"CVE-2025-1403","markdown":"https://insights.sbomify.com/CVE-2025-1403/index.md","name":"CVE-2025-1403","record":{"aliases":["GHSA-fpmr-m242-xm7x","PYSEC-2026-1859","PYSEC-2026-3045"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Qiskit SDK","requires_auth":"none","summary":"A remote attacker can cause a denial of service in Qiskit SDK by submitting a maliciously crafted QPY file that triggers a segmentation fault.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"ibm","cpe":[{"product":"qiskit","vendor":"ibm"}],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Qiskit SDK 0.45.0 through 1.2.4 could allow a remote attacker to cause a denial of service using a maliciously crafted QPY file containing a malformed symengine serialization stream which can cause a segfault within the symengine library.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Qiskit SDK denial of service","id":"CVE-2025-1403","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":6,"n_references":1,"next":{"headline":"Missing authorization in Secure Copy Content Protection and Content Locking","id":"CVE-2025-1404"},"packages":[{"ecosystem":"PyPI","fixed":["1.3.0"],"introduced":["0.45.0"],"last_affected":[],"package":"qiskit","purl":null,"source":"GHSA-fpmr-m242-xm7x"},{"ecosystem":"PyPI","fixed":["1.3.0"],"introduced":["0.45.0"],"last_affected":[],"package":"qiskit","purl":"pkg:pypi/qiskit","source":"GHSA-fpmr-m242-xm7x"},{"ecosystem":"PyPI","fixed":["1.3.0"],"introduced":["0.45.0"],"last_affected":[],"package":"qiskit","purl":"pkg:pypi/qiskit","source":"PYSEC-2026-3045"},{"ecosystem":"PyPI","fixed":[],"introduced":["0.45.0"],"last_affected":["0.46.3"],"package":"qiskit-terra","purl":null,"source":"GHSA-fpmr-m242-xm7x"},{"ecosystem":"PyPI","fixed":[],"introduced":["0.45.0"],"last_affected":["0.46.3"],"package":"qiskit-terra","purl":"pkg:pypi/qiskit-terra","source":"GHSA-fpmr-m242-xm7x"},{"ecosystem":"PyPI","fixed":[],"introduced":["0.45.0"],"last_affected":["0.46.3"],"package":"qiskit-terra","purl":"pkg:pypi/qiskit-terra","source":"PYSEC-2026-1859"}],"prev":{"headline":"Event Tickets and Registration \u003c= 5.19.1.1 - Missing Authorization to Ticket Deletion","id":"CVE-2025-1402"},"products":["Qiskit SDK"],"published":"2025-02-21","related":[{"cvss_score":9.8,"headline":"Qiskit SDK code execution","id":"CVE-2025-2000","kev_date_added":null,"published":"2025-03-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-08-26","vendors":["IBM"]},"summary":"A remote attacker can cause a denial of service in Qiskit SDK by submitting a maliciously crafted QPY file that triggers a segmentation fault.","url":"https://insights.sbomify.com/CVE-2025-1403/"}