# CVE-2025-1403: Qiskit SDK denial of service

> A remote attacker can cause a denial of service in Qiskit SDK by submitting a maliciously crafted QPY file that triggers a segmentation fault.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Feb 2025
- **Updated:** 26 Aug 2025
- **Also known as:** GHSA-fpmr-m242-xm7x, PYSEC-2026-1859, PYSEC-2026-3045

## What is CVE-2025-1403?

CVE-2025-1403 is a high-severity denial of service vulnerability in IBM Qiskit SDK, published on 21 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Qiskit SDK 0.45.0 through 1.2.4 could allow a remote attacker to cause a denial of service using a maliciously crafted QPY file containing a malformed symengine serialization stream which can cause a segfault within the symengine library.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-1403?

6 open source packages ship an affected version, including qiskit and qiskit-terra. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `qiskit` | PyPI | From 0.45.0 | 1.3.0 |
| `qiskit` | PyPI | From 0.45.0 | 1.3.0 |
| `qiskit` | PyPI | From 0.45.0 | 1.3.0 |
| `qiskit-terra` | PyPI | From 0.45.0 to 0.46.3 | None |
| `qiskit-terra` | PyPI | From 0.45.0 to 0.46.3 | None |
| `qiskit-terra` | PyPI | From 0.45.0 to 0.46.3 | None |

Products: Ibm Qiskit.

## How do I fix CVE-2025-1403?

Upgrade qiskit to 1.3.0 or later.

## Is CVE-2025-1403 being exploited?

There is no known exploitation of CVE-2025-1403 in the wild and no public exploit code.

## Other vulnerabilities in IBM Qiskit SDK

- [CVE-2025-2000](https://insights.sbomify.com/CVE-2025-2000/): Qiskit SDK code execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-1403 and fix it if it is affected.

What it is: CVE-2025-1403 is a high-severity denial of service vulnerability in IBM Qiskit SDK, published on 21 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-1403 in the wild and no public exploit code.

Affected packages and fixed versions:
- qiskit (PyPI): affected from 0.45.0; fixed in 1.3.0
- qiskit (PyPI): affected from 0.45.0; fixed in 1.3.0
- qiskit (PyPI): affected from 0.45.0; fixed in 1.3.0
- qiskit-terra (PyPI): affected from 0.45.0 up to 0.46.3; no fix listed
- qiskit-terra (PyPI): affected from 0.45.0 up to 0.46.3; no fix listed
- qiskit-terra (PyPI): affected from 0.45.0 up to 0.46.3; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-1403/ (Markdown: https://insights.sbomify.com/CVE-2025-1403/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-1403
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-1403
- OSV: https://osv.dev/vulnerability/CVE-2025-1403

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-1403/
Summaries are generated and may contain mistakes; the official description above is the record.
