# CVE-2025-1408: Missing authorization in ProfileGrid – User Profiles, Groups and Communities

> Authenticated subscribers can approve or decline group join requests due to missing capability checks in the ProfileGrid WordPress plugin.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 22 Mar 2025
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-mh84-747x-6j6c

## What is CVE-2025-1408?

CVE-2025-1408 is a medium-severity missing authorization vulnerability in metagauss ProfileGrid – User Profiles, Groups and Communities, published on 22 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The ProfileGrid – User Profiles, Groups and Communities plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the pm_decline_join_group_request and pm_approve_join_group_request functions in all versions up to, and including, 5.9.4.4. This makes it possible for authenticated attackers, with Subscriber-level access and above, to approve or decline join group requests which is normally should be available to administrators only.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2025-1408?

It affects 1 product.


Products: Metagauss Profilegrid.

## How do I fix CVE-2025-1408?

No fix has been published for CVE-2025-1408 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-1408 being exploited?

There is no known exploitation of CVE-2025-1408 in the wild and no public exploit code.

## Other vulnerabilities in metagauss ProfileGrid – User Profiles, Groups and Communities

- [CVE-2024-30490](https://insights.sbomify.com/CVE-2024-30490/): WordPress ProfileGrid plugin <= 5.7.8 - SQL Injection vulnerability (critical 9.3)
- [CVE-2025-0724](https://insights.sbomify.com/CVE-2025-0724/): ProfileGrid – User Profiles, Groups and Communities <= 5.9.4.5 - Authenticated (Subscriber+) PHP Object Injection (high 8.8)
- [CVE-2024-6411](https://insights.sbomify.com/CVE-2024-6411/): Privilege escalation in ProfileGrid – User Profiles, Groups and Communities (high 8.8)
- [CVE-2023-3713](https://insights.sbomify.com/CVE-2023-3713/): ProfileGrid <= 5.5.1 - Authenticated (Subscriber+) Arbitrary Option Update (high 8.8)
- [CVE-2023-0940](https://insights.sbomify.com/CVE-2023-0940/): ProfileGrid < 5.3.1 - Subscriber+ Arbitrary Password Reset (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-1408 and fix it if it is affected.

What it is: CVE-2025-1408 is a medium-severity missing authorization vulnerability in metagauss ProfileGrid – User Profiles, Groups and Communities, published on 22 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-1408 in the wild and no public exploit code.

Affected product: metagauss ProfileGrid – User Profiles, Groups and Communities. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-1408/ (Markdown: https://insights.sbomify.com/CVE-2025-1408/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-1408
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-1408
- OSV: https://osv.dev/vulnerability/CVE-2025-1408

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-1408/
Summaries are generated and may contain mistakes; the official description above is the record.
