{"answers":{"affected":"2 open source packages ship an affected version, including org.keycloak:keycloak-services.","exploited":"There is no known exploitation of CVE-2025-14082 in the wild and no public exploit code.","fix":"Upgrade org.keycloak:keycloak-services to 26.5.0 or later.","what":"CVE-2025-14082 is a low-severity missing authorization vulnerability in Red Hat build of Keycloak 26.4, published on 10 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-14082 and fix it if it is affected.\n\nWhat it is: CVE-2025-14082 is a low-severity missing authorization vulnerability in Red Hat build of Keycloak 26.4, published on 10 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-14082 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 26.5.0\n- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 26.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-14082/ (Markdown: https://insights.sbomify.com/CVE-2025-14082/index.md)","id":"CVE-2025-14082","markdown":"https://insights.sbomify.com/CVE-2025-14082/index.md","name":"CVE-2025-14082","record":{"aliases":["ECHO-be84-7958-aebf","GHSA-6q37-7866-h27j","MINI-whpc-9x62-jvq7","MINI-x3gf-p923-j9px"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Keycloak identity server","requires_auth":"high_privilege","summary":"Attackers can access sensitive role metadata via the Keycloak Admin REST API due to insufficient authorization checks on the roles endpoint.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[],"cvss":{"score":2.7,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"}],"description":"A flaw was found in Keycloak Admin REST (Representational State Transfer) API. This vulnerability allows information disclosure of sensitive role metadata via insufficient authorization checks on the /admin/realms/{realm}/roles endpoint.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Keycloak Admin REST (Representational State Transfer) API does not properly enforce permissions","id":"CVE-2025-14082","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2025"},"n_packages":2,"n_references":4,"next":{"headline":"Keycloak-server: keycloak: improper access control in admin rest api leads to information disclosure","id":"CVE-2025-14083"},"packages":[{"ecosystem":"Maven","fixed":["26.5.0"],"introduced":["0"],"last_affected":[],"package":"org.keycloak:keycloak-services","purl":null,"source":"GHSA-6q37-7866-h27j"},{"ecosystem":"Maven","fixed":["26.5.0"],"introduced":["0"],"last_affected":[],"package":"org.keycloak:keycloak-services","purl":"pkg:maven/org.keycloak/keycloak-services","source":"GHSA-6q37-7866-h27j"}],"prev":{"headline":"Ultimate Member \u003c= 2.11.0 - Authenticated (Subscriber+) Profile Privacy Setting Bypass","id":"CVE-2025-14081"},"products":["Red Hat build of Keycloak 26.4","Red Hat build of Keycloak 26.4.11"],"published":"2025-12-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-19","vendors":["Red Hat"]},"summary":"Attackers can access sensitive role metadata via the Keycloak Admin REST API due to insufficient authorization checks on the roles endpoint.","url":"https://insights.sbomify.com/CVE-2025-14082/"}