# CVE-2025-14082: Keycloak Admin REST (Representational State Transfer) API does not properly enforce permissions

> Attackers can access sensitive role metadata via the Keycloak Admin REST API due to insufficient authorization checks on the roles endpoint.

- **Severity:** Low 2.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Dec 2025
- **Updated:** 19 Apr 2026
- **Also known as:** ECHO-be84-7958-aebf, GHSA-6q37-7866-h27j, MINI-whpc-9x62-jvq7, MINI-x3gf-p923-j9px

## What is CVE-2025-14082?

CVE-2025-14082 is a low-severity missing authorization vulnerability in Red Hat build of Keycloak 26.4, published on 10 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A flaw was found in Keycloak Admin REST (Representational State Transfer) API. This vulnerability allows information disclosure of sensitive role metadata via insufficient authorization checks on the /admin/realms/{realm}/roles endpoint.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2025-14082?

2 open source packages ship an affected version, including org.keycloak:keycloak-services.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-services` | Maven | All versions | 26.5.0 |
| `org.keycloak:keycloak-services` | Maven | All versions | 26.5.0 |

## How do I fix CVE-2025-14082?

Upgrade org.keycloak:keycloak-services to 26.5.0 or later.

## Is CVE-2025-14082 being exploited?

There is no known exploitation of CVE-2025-14082 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-14082 and fix it if it is affected.

What it is: CVE-2025-14082 is a low-severity missing authorization vulnerability in Red Hat build of Keycloak 26.4, published on 10 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-14082 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 26.5.0
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 26.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-14082/ (Markdown: https://insights.sbomify.com/CVE-2025-14082/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-14082
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-14082
- OSV: https://osv.dev/vulnerability/CVE-2025-14082

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-14082/
Summaries are generated and may contain mistakes; the official description above is the record.
