CVE-2025-14103 Missing Authorization in GitLab
An unauthorized user with Developer permissions could set pipeline variables for manually triggered jobs, potentially altering build behavior.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-14103?
CVE-2025-14103 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 25 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 17.7 before 18.7.5, 18.8 before 18.8.5, and 18.9 before 18.9.1 that could have allowed an unauthorized user with Developer-role permissions to set pipeline variables for manually triggered jobs under certain conditions.
Weakness: CWE-862
Which versions are affected by CVE-2025-14103?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 17.7.0 | 18.7.5, 18.8.5, 18.9.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2025-14103?
Upgrade gitlab to a fixed version for your release line: 18.7.5, 18.8.5 or 18.9.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-14103 being exploited?
There is no known exploitation of CVE-2025-14103 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2025-14103, GHSA-g3hq-7735-4x6v, UBUNTU-CVE-2025-14103.