CVE-2025-1412 Session Persistence After User-to-Bot Conversion
Attackers can retain active sessions after user-to-bot conversion to escalate privileges based on bot permissions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-1412?
CVE-2025-1412 is a low-severity vulnerability in Mattermost Mattermost Server, published on 24 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 9.11.x <= 9.11.6, 10.4.x <= 10.4.1 fail to invalidate all active sessions when converting a user to a bot, with allows the converted user to escalate their privileges depending on the permissions granted to the bot.
Weakness: CWE-384
Which versions are affected by CVE-2025-1412?
10 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20241217145510-faa7e4f2ea0c |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20241217145510-faa7e4f2ea0c |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20241217145510-faa7e4f2ea0c |
github.com/mattermost/mattermost/server/v8 Go | From 10.4.0-rc1 | 10.4.2 |
github.com/mattermost/mattermost/server/v8 Go | From 10.4.0-rc1 | 10.4.2 |
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0-rc1 | 9.11.7 |
4 more packages
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0-rc1 | 9.11.7 |
github.com/mattermost/mattermost-server Go | From 9.11.0-rc1+incompatible | 9.11.7+incompatible, 10.4.2+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-1412?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20241217145510-faa7e4f2ea0c, 10.4.2 or 9.11.7.
Is CVE-2025-1412 being exploited?
There is no known exploitation of CVE-2025-1412 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-rhvr-6w8c-6v7w, GO-2025-3482.