# CVE-2025-14155: Missing authorization in Premium Addons for Elementor – Powerful Elementor Templates & Widgets

> Unauthenticated attackers can view private, draft, and pending template content due to missing capability checks in the Premium Addons for Elementor plugin.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 23 Dec 2025
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-8689-6x46-8697

## What is CVE-2025-14155?

CVE-2025-14155 is a medium-severity missing authorization vulnerability in leap13 Premium Addons for Elementor – Powerful Elementor Templates & Widgets, published on 23 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Premium Addons for Elementor – Powerful Elementor Templates & Widgets plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the 'get_template_content' function in all versions up to, and including, 4.11.53. This makes it possible for unauthenticated attackers to view the content of private, draft, and pending templates.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2025-14155?

It affects 1 product.


Products: Leap13 Premium Addons for Elementor.

## How do I fix CVE-2025-14155?

No fix has been published for CVE-2025-14155 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-14155 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14155 exists.

Public exploit code:

- Premium Addons for Elementor - Unauthenticated Information Disclosure (nuclei): http/cves/2025/CVE-2025-14155.yaml

## Other vulnerabilities in leap13 Premium Addons for Elementor – Powerful Elementor Templates & Widgets

- [CVE-2023-34012](https://insights.sbomify.com/CVE-2023-34012/): WordPress Premium Addons PRO Plugin <= 2.8.24 is vulnerable to Cross Site Scripting (XSS) (high 7.1)
- [CVE-2021-4445](https://insights.sbomify.com/CVE-2021-4445/): Premium Addons for Elementor <= 4.5.1 - Authenticated (Subscriber+) Limited Arbitrary Option Update (medium 6.5)
- [CVE-2024-37922](https://insights.sbomify.com/CVE-2024-37922/): WordPress Premium Addons for Elementor plugin <= 4.10.34 - Cross Site Scripting (XSS) vulnerability (medium 6.5)
- [CVE-2024-32791](https://insights.sbomify.com/CVE-2024-32791/): WordPress Premium Addons for Elementor plugin <= 4.10.25 - Cross Site Scripting (XSS) vulnerability (medium 6.5)
- [CVE-2024-29106](https://insights.sbomify.com/CVE-2024-29106/): WordPress Premium Addons for Elementor plugin <= 4.10.16 - Cross Site Scripting (XSS) vulnerability (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-14155 and fix it if it is affected.

What it is: CVE-2025-14155 is a medium-severity missing authorization vulnerability in leap13 Premium Addons for Elementor – Powerful Elementor Templates & Widgets, published on 23 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14155 exists.

Affected product: leap13 Premium Addons for Elementor – Powerful Elementor Templates & Widgets. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-14155/ (Markdown: https://insights.sbomify.com/CVE-2025-14155/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-14155
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-14155
- OSV: https://osv.dev/vulnerability/CVE-2025-14155

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-14155/
Summaries are generated and may contain mistakes; the official description above is the record.
