CVE-2025-14177 Information Leak of Memory in getimagesize
Attackers can leak uninitialized heap memory via getimagesize, potentially exposing sensitive server data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-14177?
CVE-2025-14177 is a medium-severity vulnerability in Php Php, published on 27 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In PHP versions:8.1.* before 8.1.34, 8.2.* before 8.2.30, 8.3.* before 8.3.29, 8.4.* before 8.4.16, 8.5.* before 8.5.1, the getimagesize() function may leak uninitialized heap memory into the APPn segments (e.g., APP1) when reading images in multi-chunk mode (such as via php://filter). This occurs due to a bug in php_read_stream_all_chunks() that overwrites the buffer without advancing the pointer, leaving tail bytes uninitialized. This may lead to information disclosure of sensitive heap data and affect the confidentiality of the target server.
Weakness: CWE-125
Which versions are affected by CVE-2025-14177?
3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
libphp Bitnami | All versions | 8.1.34, 8.2.30, 8.3.29, 8.4.16, 8.5.1 |
php Bitnami | All versions | 8.1.34, 8.2.30, 8.3.29, 8.4.16, 8.5.1 |
php-min Bitnami | All versions | 8.1.34, 8.2.30, 8.3.29, 8.4.16, 8.5.1 |
Products include Php Php.
How do I fix CVE-2025-14177?
Upgrade libphp to a fixed version for your release line: 8.1.34, 8.2.30, 8.3.29 or 8.4.16.
Is CVE-2025-14177 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14177 exists.
Public exploit code: 2 proofs of concept on GitHub.
Other vulnerabilities in Php Php
Sources
Also known as AZL-73195, AZL-73240, BELL-CVE-2025-14177, BIT-libphp-2025-14177, BIT-php-2025-14177, BIT-php-min-2025-14177 and 9 more.