{"answers":{"affected":"3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14177 exists.","fix":"Upgrade libphp to a fixed version for your release line: 8.1.34, 8.2.30, 8.3.29 or 8.4.16.","what":"CVE-2025-14177 is a medium-severity vulnerability in Php Php, published on 27 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-14177 and fix it if it is affected.\n\nWhat it is: CVE-2025-14177 is a medium-severity vulnerability in Php Php, published on 27 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14177 exists.\n\nAffected packages and fixed versions:\n- libphp (Bitnami): affected all versions; fixed in 8.1.34, 8.2.30, 8.3.29, 8.4.16, 8.5.1\n- php (Bitnami): affected all versions; fixed in 8.1.34, 8.2.30, 8.3.29, 8.4.16, 8.5.1\n- php-min (Bitnami): affected all versions; fixed in 8.1.34, 8.2.30, 8.3.29, 8.4.16, 8.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-14177/ (Markdown: https://insights.sbomify.com/CVE-2025-14177/index.md)","id":"CVE-2025-14177","markdown":"https://insights.sbomify.com/CVE-2025-14177/index.md","name":"CVE-2025-14177","record":{"aliases":["AZL-73195","AZL-73240","BELL-CVE-2025-14177","BIT-libphp-2025-14177","BIT-php-2025-14177","BIT-php-min-2025-14177","DEBIAN-CVE-2025-14177","ECHO-a583-d40b-a57d","GHSA-3237-qqm7-mfv7","MINI-2wv3-8pfc-8mc6","MINI-33xw-8ch8-r78f","MINI-fv7g-gvgm-6w8q","MINI-rcc4-5q7p-fhh5","MINI-wfp2-9368-c8f7","UBUNTU-CVE-2025-14177"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP scripting language","requires_auth":"none","summary":"Attackers can leak uninitialized heap memory via getimagesize, potentially exposing sensitive server data.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"php","cpe":[{"product":"php","vendor":"php"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"In PHP versions:8.1.* before 8.1.34, 8.2.* before 8.2.30, 8.3.* before 8.3.29, 8.4.* before 8.4.16, 8.5.* before 8.5.1, the getimagesize() function may leak uninitialized heap memory into the APPn segments (e.g., APP1) when reading images in multi-chunk mode (such as via php://filter). This occurs due to a bug in php_read_stream_all_chunks() that overwrites the buffer without advancing the pointer, leaving tail bytes uninitialized. This may lead to information disclosure of sensitive heap data and affect the confidentiality of the target server.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":"2026-04-29","github_poc":2,"max_poc_stars":1,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-04-29T03:58:13Z","kind":"github_poc","ref":"https://github.com/gl1tch0x1/PHP_8.1.x_Exploit","stars":1,"title":"Automated detection \u0026 exploitation of critical PHP vulnerabilities (CVE-2024-4577 bypass, CVE-2025-14177, CVE-2025-14180, CVE-2025-14178)"},{"date":"2026-05-18T10:00:32Z","kind":"github_poc","ref":"https://github.com/34zY/CVE-2025-14177","stars":1,"title":"PHP getimagesize() CVE-2025-14177 - Heap Memory Leak Exploit Generator Fully functional exploit chain in Python"}],"tier":"weaponised"},"has_fix":true,"headline":"Information Leak of Memory in getimagesize","id":"CVE-2025-14177","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"php:php","products":["php:php"],"type":"information_disclosure","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"Heap buffer overflow in array_merge()","id":"CVE-2025-14178"},"packages":[{"ecosystem":"Bitnami","fixed":["8.1.34","8.2.30","8.3.29","8.4.16","8.5.1"],"introduced":["0","8.2.0","8.3.0","8.4.0","8.5.0"],"last_affected":[],"package":"libphp","purl":"pkg:bitnami/libphp","source":"BIT-libphp-2025-14177"},{"ecosystem":"Bitnami","fixed":["8.1.34","8.2.30","8.3.29","8.4.16","8.5.1"],"introduced":["0","8.2.0","8.3.0","8.4.0","8.5.0"],"last_affected":[],"package":"php","purl":"pkg:bitnami/php","source":"BIT-php-2025-14177"},{"ecosystem":"Bitnami","fixed":["8.1.34","8.2.30","8.3.29","8.4.16","8.5.1"],"introduced":["0","8.2.0","8.3.0","8.4.0","8.5.0"],"last_affected":[],"package":"php-min","purl":"pkg:bitnami/php-min","source":"BIT-php-min-2025-14177"}],"prev":{"headline":"Weak Algorithm Support in SSH Server on TL-WR820N","id":"CVE-2025-14175"},"products":["PHP"],"published":"2025-12-27","related":[{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2012-2688","kev_date_added":null,"published":"2012-07-20"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2012-2376","kev_date_added":null,"published":"2012-05-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2011-3268","kev_date_added":null,"published":"2011-08-25"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2009-4143","kev_date_added":null,"published":"2009-12-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-5557","kev_date_added":null,"published":"2008-12-23"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-2050","kev_date_added":null,"published":"2008-05-05"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2008-2051","kev_date_added":null,"published":"2008-05-05"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-12-29","vendors":["PHP Group"]},"summary":"Attackers can leak uninitialized heap memory via getimagesize, potentially exposing sensitive server data.","url":"https://insights.sbomify.com/CVE-2025-14177/"}