# CVE-2025-14177: Information Leak of Memory in getimagesize

> Attackers can leak uninitialized heap memory via getimagesize, potentially exposing sensitive server data.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Dec 2025
- **Updated:** 29 Dec 2025
- **Also known as:** AZL-73195, AZL-73240, BELL-CVE-2025-14177, BIT-libphp-2025-14177, BIT-php-2025-14177, BIT-php-min-2025-14177, DEBIAN-CVE-2025-14177, ECHO-a583-d40b-a57d, GHSA-3237-qqm7-mfv7, MINI-2wv3-8pfc-8mc6, MINI-33xw-8ch8-r78f, MINI-fv7g-gvgm-6w8q, MINI-rcc4-5q7p-fhh5, MINI-wfp2-9368-c8f7, UBUNTU-CVE-2025-14177

## What is CVE-2025-14177?

CVE-2025-14177 is a medium-severity vulnerability in Php Php, published on 27 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In PHP versions:8.1.* before 8.1.34, 8.2.* before 8.2.30, 8.3.* before 8.3.29, 8.4.* before 8.4.16, 8.5.* before 8.5.1, the getimagesize() function may leak uninitialized heap memory into the APPn segments (e.g., APP1) when reading images in multi-chunk mode (such as via php://filter). This occurs due to a bug in php_read_stream_all_chunks() that overwrites the buffer without advancing the pointer, leaving tail bytes uninitialized. This may lead to information disclosure of sensitive heap data and affect the confidentiality of the target server.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2025-14177?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | All versions | 8.1.34, 8.2.30, 8.3.29, 8.4.16, 8.5.1 |
| `php` | Bitnami | All versions | 8.1.34, 8.2.30, 8.3.29, 8.4.16, 8.5.1 |
| `php-min` | Bitnami | All versions | 8.1.34, 8.2.30, 8.3.29, 8.4.16, 8.5.1 |

Products: Php Php.

## How do I fix CVE-2025-14177?

Upgrade libphp to a fixed version for your release line: 8.1.34, 8.2.30, 8.3.29 or 8.4.16.

## Is CVE-2025-14177 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14177 exists.

Public exploit code:

- Automated detection & exploitation of critical PHP vulnerabilities (CVE-2024-4577 bypass, CVE-2025-14177, CVE-2025-14180, CVE-2025-14178) (github_poc): https://github.com/gl1tch0x1/PHP_8.1.x_Exploit
- PHP getimagesize() CVE-2025-14177 - Heap Memory Leak Exploit Generator Fully functional exploit chain in Python (github_poc): https://github.com/34zY/CVE-2025-14177

## Other vulnerabilities in Php Php

- [CVE-2012-2688](https://insights.sbomify.com/CVE-2012-2688/): Integer overflow in n/a (critical 10.0)
- [CVE-2012-2376](https://insights.sbomify.com/CVE-2012-2376/): Memory corruption in n/a (critical 10.0)
- [CVE-2011-3268](https://insights.sbomify.com/CVE-2011-3268/): Memory corruption in n/a (critical 10.0)
- [CVE-2009-4143](https://insights.sbomify.com/CVE-2009-4143/): Other in n/a (critical 10.0)
- [CVE-2008-5557](https://insights.sbomify.com/CVE-2008-5557/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-14177 and fix it if it is affected.

What it is: CVE-2025-14177 is a medium-severity vulnerability in Php Php, published on 27 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14177 exists.

Affected packages and fixed versions:
- libphp (Bitnami): affected all versions; fixed in 8.1.34, 8.2.30, 8.3.29, 8.4.16, 8.5.1
- php (Bitnami): affected all versions; fixed in 8.1.34, 8.2.30, 8.3.29, 8.4.16, 8.5.1
- php-min (Bitnami): affected all versions; fixed in 8.1.34, 8.2.30, 8.3.29, 8.4.16, 8.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-14177/ (Markdown: https://insights.sbomify.com/CVE-2025-14177/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-14177
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-14177
- OSV: https://osv.dev/vulnerability/CVE-2025-14177

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-14177/
Summaries are generated and may contain mistakes; the official description above is the record.
