CVE-2025-14179 SQL injection in pdo_firebird via NUL bytes in quoted strings
SQL injection in PHP's PDO Firebird driver allows attackers to manipulate queries via NUL bytes in quoted strings, risking data exposure or modification.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-14179?
CVE-2025-14179 is a high-severity SQL injection vulnerability in Php Php, published on 10 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
In PHP versions 8.2.* before 8.2.31, 8.3.* before 8.3.31, 8.4.* before 8.4.21, and 8.5.* before 8.5.6, the PDO Firebird driver improperly handles NUL bytes when preparing SQL queries. During token-by-token query construction, a string token containing a NUL byte is copied via strncat(), which stops at the NUL byte, dropping the closing quote and causing subsequent SQL tokens to be interpreted as part of the string. This allows SQL injection when attacker-controlled values are quoted via PDO::quote() and embedded in SQL statements.
Weakness: CWE-89
Which versions are affected by CVE-2025-14179?
3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
libphp Bitnami | From 8.2.0 | 8.2.31, 8.3.31, 8.4.21, 8.5.6 |
php Bitnami | From 8.2.0 | 8.2.31, 8.3.31, 8.4.21, 8.5.6 |
php-min Bitnami | From 8.2.0 | 8.2.31, 8.3.31, 8.4.21, 8.5.6 |
Products include Php Php.
How do I fix CVE-2025-14179?
Upgrade libphp to a fixed version for your release line: 8.2.31, 8.3.31, 8.4.21 or 8.5.6.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2025-14179 being exploited?
There is no known exploitation of CVE-2025-14179 in the wild and no public exploit code.
Other vulnerabilities in Php Php
Sources
Also known as AZL-86358, BELL-CVE-2025-14179, BIT-libphp-2025-14179, BIT-php-2025-14179, BIT-php-min-2025-14179, DEBIAN-CVE-2025-14179 and 6 more.