# CVE-2025-14179: SQL injection in pdo_firebird via NUL bytes in quoted strings

> SQL injection in PHP's PDO Firebird driver allows attackers to manipulate queries via NUL bytes in quoted strings, risking data exposure or modification.

- **Severity:** High 7.4 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:P/AU:Y/RE:M/U:Amber`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 May 2026
- **Updated:** 15 Jul 2026
- **Also known as:** AZL-86358, BELL-CVE-2025-14179, BIT-libphp-2025-14179, BIT-php-2025-14179, BIT-php-min-2025-14179, DEBIAN-CVE-2025-14179, ECHO-e847-b4bc-fa2a, MINI-23f8-g2rh-6hx2, MINI-23h8-c4r5-h6r6, MINI-3h48-w737-p7w4, MINI-rj5g-pv5x-4c64, UBUNTU-CVE-2025-14179

## What is CVE-2025-14179?

CVE-2025-14179 is a high-severity SQL injection vulnerability in Php Php, published on 10 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In PHP versions 8.2.* before 8.2.31, 8.3.* before 8.3.31, 8.4.* before 8.4.21, and 8.5.* before 8.5.6, the PDO Firebird driver improperly handles NUL bytes when preparing SQL queries. During token-by-token query construction, a string token containing a NUL byte is copied via strncat(), which stops at the NUL byte, dropping the closing quote and causing subsequent SQL tokens to be interpreted as part of the string. This allows SQL injection when attacker-controlled values are quoted via PDO::quote() and embedded in SQL statements.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-14179?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | From 8.2.0 | 8.2.31, 8.3.31, 8.4.21, 8.5.6 |
| `php` | Bitnami | From 8.2.0 | 8.2.31, 8.3.31, 8.4.21, 8.5.6 |
| `php-min` | Bitnami | From 8.2.0 | 8.2.31, 8.3.31, 8.4.21, 8.5.6 |

Products: Php Php.

## How do I fix CVE-2025-14179?

Upgrade libphp to a fixed version for your release line: 8.2.31, 8.3.31, 8.4.21 or 8.5.6.

## Is CVE-2025-14179 being exploited?

There is no known exploitation of CVE-2025-14179 in the wild and no public exploit code.

## Other vulnerabilities in Php Php

- [CVE-2012-2688](https://insights.sbomify.com/CVE-2012-2688/): Integer overflow in n/a (critical 10.0)
- [CVE-2012-2376](https://insights.sbomify.com/CVE-2012-2376/): Memory corruption in n/a (critical 10.0)
- [CVE-2011-3268](https://insights.sbomify.com/CVE-2011-3268/): Memory corruption in n/a (critical 10.0)
- [CVE-2009-4143](https://insights.sbomify.com/CVE-2009-4143/): Other in n/a (critical 10.0)
- [CVE-2008-5557](https://insights.sbomify.com/CVE-2008-5557/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-14179 and fix it if it is affected.

What it is: CVE-2025-14179 is a high-severity SQL injection vulnerability in Php Php, published on 10 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-14179 in the wild and no public exploit code.

Affected packages and fixed versions:
- libphp (Bitnami): affected from 8.2.0; fixed in 8.2.31, 8.3.31, 8.4.21, 8.5.6
- php (Bitnami): affected from 8.2.0; fixed in 8.2.31, 8.3.31, 8.4.21, 8.5.6
- php-min (Bitnami): affected from 8.2.0; fixed in 8.2.31, 8.3.31, 8.4.21, 8.5.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-14179/ (Markdown: https://insights.sbomify.com/CVE-2025-14179/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-14179
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-14179
- OSV: https://osv.dev/vulnerability/CVE-2025-14179

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-14179/
Summaries are generated and may contain mistakes; the official description above is the record.
