{"answers":{"affected":"3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14180 exists.","fix":"Upgrade libphp to a fixed version for your release line: 8.1.34, 8.2.30, 8.3.29 or 8.4.16.","what":"CVE-2025-14180 is a high-severity vulnerability in Php Php, published on 27 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-14180 and fix it if it is affected.\n\nWhat it is: CVE-2025-14180 is a high-severity vulnerability in Php Php, published on 27 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14180 exists.\n\nAffected packages and fixed versions:\n- libphp (Bitnami): affected all versions; fixed in 8.1.34, 8.2.30, 8.3.29, 8.4.16, 8.5.1\n- php (Bitnami): affected all versions; fixed in 8.1.34, 8.2.30, 8.3.29, 8.4.16, 8.5.1\n- php-min (Bitnami): affected all versions; fixed in 8.1.34, 8.2.30, 8.3.29, 8.4.16, 8.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-14180/ (Markdown: https://insights.sbomify.com/CVE-2025-14180/index.md)","id":"CVE-2025-14180","markdown":"https://insights.sbomify.com/CVE-2025-14180/index.md","name":"CVE-2025-14180","record":{"aliases":["AZL-73201","AZL-73234","BELL-CVE-2025-14180","BIT-libphp-2025-14180","BIT-php-2025-14180","BIT-php-min-2025-14180","DEBIAN-CVE-2025-14180","GHSA-8xr5-qppj-gvwj","MINI-3f6p-g638-242w","MINI-3m8j-4xq4-2rq8","MINI-3w89-hx77-hprg","MINI-6878-f7mm-gcx2","MINI-j82x-635p-47f5","UBUNTU-CVE-2025-14180"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"PHP language","requires_auth":"none","summary":"A null pointer dereference in PHP's PDO PostgreSQL driver can cause server crashes when emulated prepares are enabled and invalid characters are used.","user_interaction":"not_required","vuln_class":"null_dereference"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"php","cpe":[{"product":"php","vendor":"php"}],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-476","name":"NULL Pointer Dereference"}],"description":"In PHP versions 8.1.* before 8.1.34, 8.2.* before 8.2.30, 8.3.* before 8.3.29, 8.4.* before 8.4.16, 8.5.* before 8.5.1 when using the PDO PostgreSQL driver with PDO::ATTR_EMULATE_PREPARES enabled, an invalid character sequence (such as \\x99) in a prepared statement parameter may cause the quoting function PQescapeStringConn to return NULL, leading to a null pointer dereference in pdo_parse_params() function. This may lead to crashes (segmentation fault) and affect the availability of the target server.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"NULL Pointer Dereference in PDO quoting","id":"CVE-2025-14180","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"php:php","products":["php:php"],"type":"null_dereference","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"Integer overflow to buffer overflow in soap HTTP parsing","id":"CVE-2025-14181"},"packages":[{"ecosystem":"Bitnami","fixed":["8.1.34","8.2.30","8.3.29","8.4.16","8.5.1"],"introduced":["0","8.2.0","8.3.0","8.4.0","8.5.0"],"last_affected":[],"package":"libphp","purl":"pkg:bitnami/libphp","source":"BIT-libphp-2025-14180"},{"ecosystem":"Bitnami","fixed":["8.1.34","8.2.30","8.3.29","8.4.16","8.5.1"],"introduced":["0","8.2.0","8.3.0","8.4.0","8.5.0"],"last_affected":[],"package":"php","purl":"pkg:bitnami/php","source":"BIT-php-2025-14180"},{"ecosystem":"Bitnami","fixed":["8.1.34","8.2.30","8.3.29","8.4.16","8.5.1"],"introduced":["0","8.2.0","8.3.0","8.4.0","8.5.0"],"last_affected":[],"package":"php-min","purl":"pkg:bitnami/php-min","source":"BIT-php-min-2025-14180"}],"prev":{"headline":"SQL injection in pdo_firebird via NUL bytes in quoted strings","id":"CVE-2025-14179"},"products":["PHP"],"published":"2025-12-27","related":[{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2012-2688","kev_date_added":null,"published":"2012-07-20"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2012-2376","kev_date_added":null,"published":"2012-05-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2011-3268","kev_date_added":null,"published":"2011-08-25"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2009-4143","kev_date_added":null,"published":"2009-12-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-5557","kev_date_added":null,"published":"2008-12-23"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-2050","kev_date_added":null,"published":"2008-05-05"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2008-2051","kev_date_added":null,"published":"2008-05-05"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-12-29","vendors":["PHP Group"]},"summary":"A null pointer dereference in PHP's PDO PostgreSQL driver can cause server crashes when emulated prepares are enabled and invalid characters are used.","url":"https://insights.sbomify.com/CVE-2025-14180/"}