CVE-2025-14280 PixelYourSite <= 11.1.5 - Sensitive Information Exposure via Log File

Medium 5.3 Published Updated

Unauthenticated attackers can view sensitive data in exposed log files if the Meta API logs setting is enabled.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-14280?

CVE-2025-14280 is a medium-severity vulnerability in PixelYourSite – Your smart PIXEL (TAG) & API Manager, published on 29 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The PixelYourSite plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 11.1.5 through publicly exposed log files. This makes it possible for unauthenticated attackers to view potentially sensitive information contained in the exposed log files, when the "Meta API logs" setting is enabled (disabled by default). The vulnerability was partially patched in version 11.1.5 and fully patched in version 11.1.5.1.

Weakness: CWE-200

Which versions are affected by CVE-2025-14280?

How do I fix CVE-2025-14280?

No fix has been published for CVE-2025-14280 yet. Limit exposure of the affected software until one is available.

Is CVE-2025-14280 being exploited?

There is no known exploitation of CVE-2025-14280 in the wild and no public exploit code.

Sources

Also known as GHSA-r87x-jm9x-rwc9.

Is CVE-2025-14280 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free