{"answers":{"affected":"2 open source packages ship an affected version, including @tiptap/extension-link. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14284 exists.","fix":"Upgrade @tiptap/extension-link to 2.10.4 or later.","what":"CVE-2025-14284 is a medium-severity cross-site scripting vulnerability in @tiptap/extension-link, published on 9 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-14284 and fix it if it is affected.\n\nWhat it is: CVE-2025-14284 is a medium-severity cross-site scripting vulnerability in @tiptap/extension-link, published on 9 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14284 exists.\n\nAffected packages and fixed versions:\n- @tiptap/extension-link (npm): affected all versions; fixed in 2.10.4\n- @tiptap/extension-link (npm): affected all versions; fixed in 2.10.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-14284/ (Markdown: https://insights.sbomify.com/CVE-2025-14284/index.md)","id":"CVE-2025-14284","markdown":"https://insights.sbomify.com/CVE-2025-14284/index.md","name":"CVE-2025-14284","record":{"aliases":["GHSA-vhrc-hgrq-x75r"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Tiptap link extension","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript via unsanitized link inputs in the Tiptap editor, requiring an upgrade to the extension package.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"tiptap\\/extension-link","vendor":"tiptap"}],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Versions of the package @tiptap/extension-link before 2.10.4 are vulnerable to Cross-site Scripting (XSS) due to unsanitized user input allowed in setting or toggling links. An attacker can execute arbitrary JavaScript code in the context of the application by injecting a javascript: URL payload into these attributes, which is then triggered either by user interaction.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"@tiptap/extension-link vulnerable to Cross-site Scripting (XSS)","id":"CVE-2025-14284","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":4,"next":{"headline":"code-projects Employee Profile Management System edit_personnel.php sql injection","id":"CVE-2025-14285"},"packages":[{"ecosystem":"npm","fixed":["2.10.4"],"introduced":["0"],"last_affected":[],"package":"@tiptap/extension-link","purl":null,"source":"GHSA-vhrc-hgrq-x75r"},{"ecosystem":"npm","fixed":["2.10.4"],"introduced":["0"],"last_affected":[],"package":"@tiptap/extension-link","purl":"pkg:npm/%40tiptap/extension-link","source":"GHSA-vhrc-hgrq-x75r"}],"prev":{"headline":"Cross-site scripting in BlockArt Blocks – Gutenberg Blocks, Page Builder Blocks ,WordPress Block Plugin, Sections \u0026 Template Library","id":"CVE-2025-14283"},"products":["@tiptap/extension-link"],"published":"2025-12-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-12-09","vendors":["n/a"]},"summary":"Attackers can execute arbitrary JavaScript via unsanitized link inputs in the Tiptap editor, requiring an upgrade to the extension package.","url":"https://insights.sbomify.com/CVE-2025-14284/"}