# CVE-2025-14284: @tiptap/extension-link vulnerable to Cross-site Scripting (XSS)

> Attackers can execute arbitrary JavaScript via unsanitized link inputs in the Tiptap editor, requiring an upgrade to the extension package.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Dec 2025
- **Updated:** 9 Dec 2025
- **Also known as:** GHSA-vhrc-hgrq-x75r

## What is CVE-2025-14284?

CVE-2025-14284 is a medium-severity cross-site scripting vulnerability in @tiptap/extension-link, published on 9 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Versions of the package @tiptap/extension-link before 2.10.4 are vulnerable to Cross-site Scripting (XSS) due to unsanitized user input allowed in setting or toggling links. An attacker can execute arbitrary JavaScript code in the context of the application by injecting a javascript: URL payload into these attributes, which is then triggered either by user interaction.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-14284?

2 open source packages ship an affected version, including @tiptap/extension-link. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@tiptap/extension-link` | npm | All versions | 2.10.4 |
| `@tiptap/extension-link` | npm | All versions | 2.10.4 |

Products: Tiptap Tiptap\/Extension-Link.

## How do I fix CVE-2025-14284?

Upgrade @tiptap/extension-link to 2.10.4 or later.

## Is CVE-2025-14284 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14284 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-14284 and fix it if it is affected.

What it is: CVE-2025-14284 is a medium-severity cross-site scripting vulnerability in @tiptap/extension-link, published on 9 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14284 exists.

Affected packages and fixed versions:
- @tiptap/extension-link (npm): affected all versions; fixed in 2.10.4
- @tiptap/extension-link (npm): affected all versions; fixed in 2.10.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-14284/ (Markdown: https://insights.sbomify.com/CVE-2025-14284/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-14284
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-14284
- OSV: https://osv.dev/vulnerability/CVE-2025-14284

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-14284/
Summaries are generated and may contain mistakes; the official description above is the record.
