CVE-2025-14287 Command Injection in mlflow/mlflow

High 7.5 Published Updated

Attackers can execute arbitrary commands via malicious container image names in the MLflow CLI, affecting developers and CI/CD pipelines.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-14287?

CVE-2025-14287 is a high-severity command injection vulnerability in Lfprojects Mlflow, published on 15 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

A command injection vulnerability exists in mlflow/mlflow versions before v3.7.0, specifically in the `mlflow/sagemaker/__init__.py` file at lines 161-167. The vulnerability arises from the direct interpolation of user-supplied container image names into shell commands without proper sanitization, which are then executed using `os.system()`. This allows attackers to execute arbitrary commands by supplying malicious input through the `--container` parameter of the CLI. The issue affects environments where MLflow is used, including development setups, CI/CD pipelines, and cloud deployments.

Weakness: CWE-78, CWE-94

Which versions are affected by CVE-2025-14287?

4 open source packages ship an affected version, including mlflow. It affects 1 product.

PackageAffectedFixed in
mlflow BitnamiAll versions3.7.0
mlflow PyPIAll versions3.8.0rc0
mlflow PyPIAll versions3.8.0rc0
mlflow PyPIAll versions3.8.0rc0

Products include Lfprojects Mlflow.

How do I fix CVE-2025-14287?

Upgrade mlflow to a fixed version for your release line: 3.7.0 or 3.8.0rc0.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2025-14287 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14287 exists.

All Lfprojects Mlflow vulnerabilities

Sources

Also known as BIT-mlflow-2025-14287, GHSA-xch3-2f9x-wh9f, PYSEC-2026-2661.

Is CVE-2025-14287 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free