# CVE-2025-14287: Command Injection in mlflow/mlflow

> Attackers can execute arbitrary commands via malicious container image names in the MLflow CLI, affecting developers and CI/CD pipelines.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Mar 2026
- **Updated:** 15 Jul 2026
- **Also known as:** BIT-mlflow-2025-14287, GHSA-xch3-2f9x-wh9f, PYSEC-2026-2661

## What is CVE-2025-14287?

CVE-2025-14287 is a high-severity command injection vulnerability in Lfprojects Mlflow, published on 15 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A command injection vulnerability exists in mlflow/mlflow versions before v3.7.0, specifically in the `mlflow/sagemaker/__init__.py` file at lines 161-167. The vulnerability arises from the direct interpolation of user-supplied container image names into shell commands without proper sanitization, which are then executed using `os.system()`. This allows attackers to execute arbitrary commands by supplying malicious input through the `--container` parameter of the CLI. The issue affects environments where MLflow is used, including development setups, CI/CD pipelines, and cloud deployments.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2025-14287?

4 open source packages ship an affected version, including mlflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mlflow` | Bitnami | All versions | 3.7.0 |
| `mlflow` | PyPI | All versions | 3.8.0rc0 |
| `mlflow` | PyPI | All versions | 3.8.0rc0 |
| `mlflow` | PyPI | All versions | 3.8.0rc0 |

Products: Lfprojects Mlflow.

## How do I fix CVE-2025-14287?

Upgrade mlflow to a fixed version for your release line: 3.7.0 or 3.8.0rc0.

## Is CVE-2025-14287 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14287 exists.

## Other vulnerabilities in Lfprojects Mlflow

- [CVE-2026-64849](https://insights.sbomify.com/CVE-2026-64849/): MLflow Server-Side Request Forgery (critical 9.3, exploited in the wild)
- [CVE-2025-15379](https://insights.sbomify.com/CVE-2025-15379/): Command Injection in mlflow/mlflow (critical 10.0)
- [CVE-2024-0520](https://insights.sbomify.com/CVE-2024-0520/): Remote Code Execution due to Full Controlled File Write in mlflow/mlflow (critical 10.0)
- [CVE-2023-6977](https://insights.sbomify.com/CVE-2023-6977/): Path Traversal: '\..\filename' (critical 10.0)
- [CVE-2023-6709](https://insights.sbomify.com/CVE-2023-6709/): Improper Neutralization of Special Elements Used in a Template Engine in mlflow/mlflow (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-14287 and fix it if it is affected.

What it is: CVE-2025-14287 is a high-severity command injection vulnerability in Lfprojects Mlflow, published on 15 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14287 exists.

Affected packages and fixed versions:
- mlflow (Bitnami): affected all versions; fixed in 3.7.0
- mlflow (PyPI): affected all versions; fixed in 3.8.0rc0
- mlflow (PyPI): affected all versions; fixed in 3.8.0rc0
- mlflow (PyPI): affected all versions; fixed in 3.8.0rc0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-14287/ (Markdown: https://insights.sbomify.com/CVE-2025-14287/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-14287
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-14287
- OSV: https://osv.dev/vulnerability/CVE-2025-14287

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-14287/
Summaries are generated and may contain mistakes; the official description above is the record.
