# CVE-2025-14350: Information disclosure via channel mentions in posts

> Authenticated users can discover private team names and URLs by observing API responses to channel mentions, exposing sensitive organizational structure.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Feb 2026
- **Updated:** 17 Feb 2026
- **Also known as:** GHSA-57cc-2pf4-mhmx, GO-2026-4521

## What is CVE-2025-14350?

CVE-2025-14350 is a medium-severity vulnerability in Mattermost Mattermost Server, published on 16 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost versions 11.1.x <= 11.1.2, 10.11.x <= 10.11.9, 11.2.x <= 11.2.1 fail to properly validate team membership when processing channel mentions which allows authenticated users to determine the existence of teams and their URL names via posting channel shortlinks and observing the channel_mentions property in the API response. Mattermost Advisory ID: MMSA-2025-00563

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2025-14350?

17 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server` | Go | All versions | None |
| `github.com/mattermost/mattermost-server` | Go | All versions | 5.3.2-0.20251209134645-761e56bb11cc |
| `github.com/mattermost/mattermost-server` | Go | All versions | 5.3.2-0.20251209134645-761e56bb11cc |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0 | None |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0 | None |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0+incompatible | None |
| `github.com/mattermost/mattermost-server` | Go | From 11.1.0 | None |
| `github.com/mattermost/mattermost-server` | Go | From 11.1.0 | None |
| `github.com/mattermost/mattermost-server` | Go | From 11.1.0+incompatible | None |
| `github.com/mattermost/mattermost-server` | Go | From 11.2.0 | None |
| `github.com/mattermost/mattermost-server` | Go | From 11.2.0 | None |
| `github.com/mattermost/mattermost-server` | Go | From 11.2.0+incompatible | None |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20251209134645-761e56bb11cc |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20251209134645-761e56bb11cc |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20251209134645-761e56bb11cc |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2025-14350?

Upgrade github.com/mattermost/mattermost-server to 5.3.2-0.20251209134645-761e56bb11cc or later.

## Is CVE-2025-14350 being exploited?

There is no known exploitation of CVE-2025-14350 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-14350 and fix it if it is affected.

What it is: CVE-2025-14350 is a medium-severity vulnerability in Mattermost Mattermost Server, published on 16 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-14350 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server (Go): affected all versions; fixed in 5.3.2-0.20251209134645-761e56bb11cc
- github.com/mattermost/mattermost-server (Go): affected all versions; fixed in 5.3.2-0.20251209134645-761e56bb11cc
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0; no fix listed
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0; no fix listed
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0+incompatible; no fix listed
- github.com/mattermost/mattermost-server (Go): affected from 11.1.0; no fix listed
- github.com/mattermost/mattermost-server (Go): affected from 11.1.0; no fix listed
- github.com/mattermost/mattermost-server (Go): affected from 11.1.0+incompatible; no fix listed
- github.com/mattermost/mattermost-server (Go): affected from 11.2.0; no fix listed
- github.com/mattermost/mattermost-server (Go): affected from 11.2.0; no fix listed
- github.com/mattermost/mattermost-server (Go): affected from 11.2.0+incompatible; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-14350/ (Markdown: https://insights.sbomify.com/CVE-2025-14350/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-14350
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-14350
- OSV: https://osv.dev/vulnerability/CVE-2025-14350

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-14350/
Summaries are generated and may contain mistakes; the official description above is the record.
