CVE-2025-14435 Application-Level DoS via infinite re-render loop in user profile handling
Authenticated users can cause application-level denial of service by triggering infinite re-render loops in user profile handling.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-14435?
CVE-2025-14435 is a medium-severity denial of service vulnerability in Mattermost Mattermost Server, published on 16 Jan 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Mattermost versions 10.11.x <= 10.11.8, 11.1.x <= 11.1.1, 11.0.x <= 11.0.6 fail to prevent infinite re-renders on API errors which allows authenticated users to cause application-level DoS via triggering unbounded component re-render loops.
Weakness: CWE-770
Which versions are affected by CVE-2025-14435?
7 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.9 |
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.9 |
github.com/mattermost/mattermost-server Go | From 10.11.0+incompatible | 10.11.9+incompatible, 11.0.7+incompatible, 11.1.2+incompatible |
github.com/mattermost/mattermost-server Go | From 11.0.0 | 11.0.7 |
github.com/mattermost/mattermost-server Go | From 11.0.0 | 11.0.7 |
github.com/mattermost/mattermost-server Go | From 11.1.0 | 11.1.2 |
1 more packages
github.com/mattermost/mattermost-server Go | From 11.1.0 | 11.1.2 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-14435?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.9, 10.11.9+incompatible, 11.0.7+incompatible or 11.1.2+incompatible.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-14435 being exploited?
There is no known exploitation of CVE-2025-14435 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-mx8m-v8qm-xwr8, GO-2026-4326.