CVE-2025-14503 Overly Permissive Trust Policy in Harmonix on AWS EKS

High 8.6 Published Updated

Overly permissive IAM trust policy allows same-account principals to assume administrative roles, enabling privilege escalation in Harmonix on AWS.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-14503?

CVE-2025-14503 is a high-severity vulnerability in Harmonix on AWS, published on 15 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

An overly-permissive IAM trust policy in the Harmonix on AWS framework may allow IAM principals in the same AWS account to escalate privileges via role assumption. The sample code for the EKS environment provisioning role is configured to trust the account root principal, which may enable any IAM principal in the same AWS account with sts:AssumeRole permissions to assume the role with administrative privileges.

We recommend customers upgrade to Harmonix on AWS v0.4.2 or later if you have deployed the framework using versions v0.3.0 through v0.4.1.

Weakness: CWE-266

Which versions are affected by CVE-2025-14503?

It affects 1 product.

Products include Amazon Harmonix.

How do I fix CVE-2025-14503?

No fix has been published for CVE-2025-14503 yet. Limit exposure of the affected software until one is available.

Is CVE-2025-14503 being exploited?

There is no known exploitation of CVE-2025-14503 in the wild and no public exploit code.

Sources

Also known as GHSA-qm86-gqrq-mqcw.

Is CVE-2025-14503 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free