{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-14503 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-14503 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-14503 is a high-severity vulnerability in Harmonix on AWS, published on 15 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-14503 and fix it if it is affected.\n\nWhat it is: CVE-2025-14503 is a high-severity vulnerability in Harmonix on AWS, published on 15 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-14503 in the wild and no public exploit code.\n\nAffected product: Harmonix on AWS. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-14503/ (Markdown: https://insights.sbomify.com/CVE-2025-14503/index.md)","id":"CVE-2025-14503","markdown":"https://insights.sbomify.com/CVE-2025-14503/index.md","name":"CVE-2025-14503","record":{"aliases":["GHSA-qm86-gqrq-mqcw"],"analysis":{"component_type":"cloud_service","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"AWS EKS framework","requires_auth":"high_privilege","summary":"Overly permissive IAM trust policy allows same-account principals to assume administrative roles, enabling privilege escalation in Harmonix on AWS.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"AMZN","cpe":[{"product":"harmonix","vendor":"amazon"}],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-266","name":"Incorrect Privilege Assignment"}],"description":"An overly-permissive IAM trust policy in the Harmonix on AWS framework may allow IAM principals in the same AWS account to escalate privileges via role assumption. The sample code for the EKS environment provisioning role is configured to trust the account root principal, which may enable any IAM principal in the same AWS account with sts:AssumeRole permissions to assume the role with administrative privileges.\n\nWe recommend customers upgrade to Harmonix on AWS v0.4.2 or later if you have deployed the framework using versions v0.3.0 through v0.4.1.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Overly Permissive Trust Policy in Harmonix on AWS EKS","id":"CVE-2025-14503","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"privilege_escalation","year":"2025"},"n_packages":0,"n_references":3,"next":{"headline":"IBM Sterling B2B Integrator and IBM Sterling File Gateway Cross-Site Scripting","id":"CVE-2025-14504"},"packages":[],"prev":{"headline":"News and Blog Designer Bundle \u003c= 1.1 - Unauthenticated Local File Inclusion","id":"CVE-2025-14502"},"products":["Harmonix on AWS"],"published":"2025-12-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-02-26","vendors":["AWS"]},"summary":"Overly permissive IAM trust policy allows same-account principals to assume administrative roles, enabling privilege escalation in Harmonix on AWS.","url":"https://insights.sbomify.com/CVE-2025-14503/"}