# CVE-2025-14503: Overly Permissive Trust Policy in Harmonix on AWS EKS

> Overly permissive IAM trust policy allows same-account principals to assume administrative roles, enabling privilege escalation in Harmonix on AWS.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Dec 2025
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-qm86-gqrq-mqcw

## What is CVE-2025-14503?

CVE-2025-14503 is a high-severity vulnerability in Harmonix on AWS, published on 15 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

An overly-permissive IAM trust policy in the Harmonix on AWS framework may allow IAM principals in the same AWS account to escalate privileges via role assumption. The sample code for the EKS environment provisioning role is configured to trust the account root principal, which may enable any IAM principal in the same AWS account with sts:AssumeRole permissions to assume the role with administrative privileges.

We recommend customers upgrade to Harmonix on AWS v0.4.2 or later if you have deployed the framework using versions v0.3.0 through v0.4.1.

Weakness: CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2025-14503?

It affects 1 product.


Products: Amazon Harmonix.

## How do I fix CVE-2025-14503?

No fix has been published for CVE-2025-14503 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-14503 being exploited?

There is no known exploitation of CVE-2025-14503 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-14503 and fix it if it is affected.

What it is: CVE-2025-14503 is a high-severity vulnerability in Harmonix on AWS, published on 15 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-14503 in the wild and no public exploit code.

Affected product: Harmonix on AWS. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-14503/ (Markdown: https://insights.sbomify.com/CVE-2025-14503/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-14503
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-14503
- OSV: https://osv.dev/vulnerability/CVE-2025-14503

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-14503/
Summaries are generated and may contain mistakes; the official description above is the record.
