CVE-2025-14511 Improper Validation of Specified Quantity in Input in GitLab

High 7.5 Published Updated

Unauthenticated attackers can cause denial of service by sending crafted files to the container registry endpoint under specific conditions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-14511?

CVE-2025-14511 is a high-severity denial of service vulnerability in Gitlab Gitlab, published on 25 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 12.2 before 18.7.5, 18.8 before 18.8.5, and 18.9 before 18.9.1 that could have allowed an unauthenticated user to cause denial of service by sending specially crafted files to the container registry event endpoint under certain conditions.

Weakness: CWE-1284

Which versions are affected by CVE-2025-14511?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 12.2.018.7.5, 18.8.5, 18.9.1

Products include Gitlab Gitlab.

How do I fix CVE-2025-14511?

Upgrade gitlab to a fixed version for your release line: 18.7.5, 18.8.5 or 18.9.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-14511 being exploited?

There is no known exploitation of CVE-2025-14511 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-14511, GHSA-rwv9-wgmx-5vq4, UBUNTU-CVE-2025-14511.

Is CVE-2025-14511 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free