CVE-2025-14513 Improper Validation of Specified Quantity in Input in GitLab

High 7.5 Published Updated

An unauthenticated attacker can cause a denial of service in GitLab by sending specially crafted JSON payloads to the protected branches API.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-14513?

CVE-2025-14513 is a high-severity denial of service vulnerability in Gitlab Gitlab, published on 11 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 16.11 before 18.7.6, 18.8 before 18.8.6, and 18.9 before 18.9.2 that could have allowed an unauthenticated user to cause a denial of service condition due to improper input validation when processing specially crafted JSON payloads in the protected branches API.

Weakness: CWE-1284

Which versions are affected by CVE-2025-14513?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 16.11.018.7.6, 18.8.6, 18.9.2

Products include Gitlab Gitlab.

How do I fix CVE-2025-14513?

Upgrade gitlab to a fixed version for your release line: 18.7.6, 18.8.6 or 18.9.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-14513 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14513 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-14513, GHSA-wj4p-jhrc-wr8q, UBUNTU-CVE-2025-14513.

Is CVE-2025-14513 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free