{"answers":{"affected":"3 open source packages ship an affected version, including utcp.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14542 exists.","fix":"Upgrade utcp to 1.1.0 or later.","what":"CVE-2025-14542 is a high-severity command injection vulnerability in utcp, published on 13 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-14542 and fix it if it is affected.\n\nWhat it is: CVE-2025-14542 is a high-severity command injection vulnerability in utcp, published on 13 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14542 exists.\n\nAffected packages and fixed versions:\n- utcp (PyPI): affected all versions; fixed in 1.1.0\n- utcp (PyPI): affected all versions; fixed in 1.1.0\n- utcp (PyPI): affected all versions; fixed in 1.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-14542/ (Markdown: https://insights.sbomify.com/CVE-2025-14542/index.md)","id":"CVE-2025-14542","markdown":"https://insights.sbomify.com/CVE-2025-14542/index.md","name":"CVE-2025-14542","record":{"aliases":["GHSA-75mj-4g74-9rg2","PYSEC-2026-2000"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python UTCP library","requires_auth":"none","summary":"Attackers can achieve remote code execution by serving a malicious Manual specification to clients fetching tools from a remote endpoint.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"JFROG","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-501","name":"Trust Boundary Violation"}],"description":"The vulnerability arises when a client fetches a tools’ JSON specification, known as a Manual, from a remote Manual Endpoint. While a provider may initially serve a benign manual (e.g., one defining an HTTP tool call), earning the clients’ trust, a malicious provider can later change the manual to exploit the client.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Universal Tool Calling Protocol (UTCP) client library for Python vulnerable to Trust Boundary Violation through Manual JSON specification","id":"CVE-2025-14542","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"command_injection","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"XML external entity in Connext Professional","id":"CVE-2025-14543"},"packages":[{"ecosystem":"PyPI","fixed":["1.1.0"],"introduced":["0"],"last_affected":[],"package":"utcp","purl":null,"source":"GHSA-75mj-4g74-9rg2"},{"ecosystem":"PyPI","fixed":["1.1.0"],"introduced":["0"],"last_affected":[],"package":"utcp","purl":"pkg:pypi/utcp","source":"GHSA-75mj-4g74-9rg2"},{"ecosystem":"PyPI","fixed":["1.1.0"],"introduced":["0"],"last_affected":[],"package":"utcp","purl":"pkg:pypi/utcp","source":"PYSEC-2026-2000"}],"prev":{"headline":"Lucky Wheel Giveaway \u003c= 1.0.22 - Authenticated (Administrator+) Remote Code Execution via 'conditional_tags' Parameter","id":"CVE-2025-14541"},"products":[],"published":"2025-12-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-12-13","vendors":[]},"summary":"Attackers can achieve remote code execution by serving a malicious Manual specification to clients fetching tools from a remote endpoint.","url":"https://insights.sbomify.com/CVE-2025-14542/"}