# CVE-2025-14542: Universal Tool Calling Protocol (UTCP) client library for Python vulnerable to Trust Boundary Violation through Manual JSON specification

> Attackers can achieve remote code execution by serving a malicious Manual specification to clients fetching tools from a remote endpoint.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Dec 2025
- **Updated:** 13 Dec 2025
- **Also known as:** GHSA-75mj-4g74-9rg2, PYSEC-2026-2000

## What is CVE-2025-14542?

CVE-2025-14542 is a high-severity command injection vulnerability in utcp, published on 13 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The vulnerability arises when a client fetches a tools’ JSON specification, known as a Manual, from a remote Manual Endpoint. While a provider may initially serve a benign manual (e.g., one defining an HTTP tool call), earning the clients’ trust, a malicious provider can later change the manual to exploit the client.

Weakness: CWE-501 (Trust Boundary Violation)

## Which versions are affected by CVE-2025-14542?

3 open source packages ship an affected version, including utcp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `utcp` | PyPI | All versions | 1.1.0 |
| `utcp` | PyPI | All versions | 1.1.0 |
| `utcp` | PyPI | All versions | 1.1.0 |

## How do I fix CVE-2025-14542?

Upgrade utcp to 1.1.0 or later.

## Is CVE-2025-14542 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14542 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-14542 and fix it if it is affected.

What it is: CVE-2025-14542 is a high-severity command injection vulnerability in utcp, published on 13 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14542 exists.

Affected packages and fixed versions:
- utcp (PyPI): affected all versions; fixed in 1.1.0
- utcp (PyPI): affected all versions; fixed in 1.1.0
- utcp (PyPI): affected all versions; fixed in 1.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-14542/ (Markdown: https://insights.sbomify.com/CVE-2025-14542/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-14542
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-14542
- OSV: https://osv.dev/vulnerability/CVE-2025-14542

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-14542/
Summaries are generated and may contain mistakes; the official description above is the record.
